[mythtv] DVB-S tuning failure

Gernot Pansy pansyg at gmx.at
Mon Jul 17 12:28:11 UTC 2006

i had the same issues but with another card. daniel told me that the problem 
is fixed in the diseqc branch. i switched over, and the problem was gone :-)

On Monday 17 July 2006 13:59, Paul Raison wrote:
>  I'm seeing exactly the same problem with the same card. The problem has
> only occurred within the last 2-3 weeks in SVN as the version from then was
> working with no problems. The initial mux tunes fine when Mythbackend
> starts, but subsequent tunings fail (but appears as ok in log) just that
> the channel cant be found in the PAT (as it's still tuned to the old
> frequency).
>  Mr Paul Raison
> On Jul 17, 2006 08:01 AM, Neil Garratt <ngarratt at gmail.com> wrote:
> > I've upgraded from an older 0.18 head to a fairly recent head [10507],
> > but I'm picking up a tuning problem on my Nexus-S. Looking at the logs
> > I can see a tuning attempt is made to the correct frequency and
> > polarity, it reports success, but it hasn't actually done anything.
> >
> > In the attached log, it was meant to tune to 11090000/V, but the PAT
> > shown in the log is from 11010000/V (the mux from startup). Tuning
> > returns almost immediately with apparent success, but I've confirmed
> > with other dvb tools that it's still tuned to the old mux.
> >
> > This only seems to happen with changes between a couple of muxes. If I
> > switch directly between 11010000/V and 11090000/V I get a tuning
> > mismatch, but if I switch to 11594000/V in between then it works
> > correctly.
> >
> > I'm running kernel with a standard Universal LNB (no other
> > DiSEqC devices)
> >
> > I've gone back to the older 0.18 release to make sure it wasn't a
> > hardware fault, and this version works correctly.
> >
> >
> > I've had to apply the hack in ticket #1970 to disable the extra PMT
> > filters, but I don't think this would have any effect on this problem.
> > I'll have a look at this further when the tuning works correctly (my
> > card doesn't lock up like the one reported in the ticket, it just
> > doesn't get any data)
> >
> > Neil

More information about the mythtv-dev mailing list