[mythtv] LiveTV problem

raptor jr raptorjr at hotmail.com
Tue Jan 24 07:46:15 UTC 2006

I have had a sync problem in LiveTV/recordings for some months now.
I always belived that it was a ivtv problem, and tried older versions 
without any luck.
Yesterday i took the time to try to investigate what was the cause of the 
Strangely as far as i could understand, it was MythTV that was the cause of 
the problem.
So, what happened and what did i try?

I did go back to ivtv-0.3.3 and used "mplayer /dev/video0" to see if i had 
any problem.
Well, i could show TV, but only one time, and MythTV did segfault and failed 
to start
LiveTV some times, so i guess MythTV didn't like that version. But mplayer 
played fine.
No stuttering.

So i moved on with the versions of ivtv. Using mplayer everything was fine, 
but MythTV
still didn't like older ivtv versions. But i was a bit confused that mplayer 
worked. I'm sure i have
tried that before.

Finally i installed the latest stable ivtv, version 0.4.2, rebooted and 
tried mplayer. Video/audio
was smooth as a baby. And i knew MythTV could start LiveTV with this ivtv 
version. So
i started MythTV and LiveTV, and the stuttering began.
I quit MythTV and tried mplayer again, and now the stuttering was there too.

In conclusion.
ivtv-0.4.2=>rebooted system=>mplayer == works perfect.
If i start LiveTV i get stuttering, even after quitting MythTv and trying 
mplayer again, need to
reboot to get TV smooth again.

Sure, it could be something with my system that is wrong. But it feels 
strange that when running
LiveTV the problem begins, and i can't get rid of them without rebooting.

All this was tried with MythTV0.18.2 and the SVN version as of yesterday. 
Same problem.
I have tried various settings in the Playback, audio buffering, realtime 
priority and everything else
i could think of.
There is no abnormal CPU usage, about 45%, and no peeks when the stuttering 
I have a PVR-250 tv-card.

I was waiting for someone else to have this problem, but it seems that i'm 
the only one?
I won't put this in trac because i will only get a "works for me=>closed" 

But maybe someone with a little more knowledge about linux and mythtv can 
help me to find
out why i have this problem. Is it my system or MythTv?

Don't really know what more information could be needed to help me, but i 
submit my log
from a session and maybe someone could se the problem there. I used 
"mythfrontend -v playback" for this log.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: myth.log
Url: http://mythtv.org/pipermail/mythtv-dev/attachments/20060124/2ab5d8b6/myth.diff

More information about the mythtv-dev mailing list