[mythtv] SVN 8625 Firewire capture glitching while test-mpeg2 doesn't

Steve Adeff adeffs at gmail.com
Sat Jan 21 15:08:37 UTC 2006

On Thursday 19 January 2006 15:42, Steve Adeff wrote:
> With Jim Westfall's help I've yet get a 0bit firewire recording, its worked
> everytime. What I notice though is a lot of glitches in the capture. Sample
> log output:
> 2006-01-19 14:46:12.625 audio waiting for space on soundcard: have 2752
> need 6144
> [mpeg2video @ 0x2aaaabffa4c0]MPEG motion vector out of boundary
> [mpeg2video @ 0x2aaaabffa4c0]MPEG motion vector out of boundary
> [mpeg2video @ 0x2aaaabffa4c0]Warning MVs not available
> [mpeg2video @ 0x2aaaabffa4c0]concealing 4265 DC, 4265 AC, 4265 MV errors
> 2006-01-19 14:46:12.640 audio waiting for space on soundcard: have 5760
> need 6144
> depending on the glitch, I may receive between 4-40+ lines like this every
> 2minutes or so.
> As an experiement, I ran a test-mpeg2 capture on the same channel (though
> the channel doesn't matter), grabbed 1.8GB and played through the internal
> player using MythVideo. This method results in a glitch free capture for
> the 17mins of video.
> For MythTV I have the Firewire port set to record via "broadcast",
> previously I had it set to "p2p" as it is what worked when testing with
> test-mpeg2.
> Here's my plugreport for the capture from test-mpeg2:
> Node 2 GUID 0x000e5cfffed720aa
> ------------------------------
> oMPR n_plugs=1, data_rate=2, bcast_channel=63
> oPCR[0] online=1, bcast_connection=0, n_p2p_connections=1
>         channel=63, data_rate=2, overhead_id=0, payload=376
> iMPR n_plugs=0, data_rate=2
> So then I tried switching mythtv-setup back to a p2p connection to see if
> that fixes the glitches, but it still gets the glitches and doesn't alway
> get a stream.
> Now I've got mythtv-setup back to broadcast and its working like it was
> before, and for kicks did another test-mpeg2 capture this time on another
> channel, another 1.2GB and again using the internal player I get no
> glitches playing it back (verified by a search through the frontend log).
> so it looks like somethings wrong with how MythTV captures via the
> firewire, and I'll be happy to try and help find the problem if anyone has
> anything for me to try.

Anybody? The glitches have also caused mythfrontend to crash occasionaly, and 
I still can't get test-mpeg2 to make a bad capture.


More information about the mythtv-dev mailing list