[mythtv] HD3000 issues?

Robert LeBlanc robert at leblancnet.us
Wed Jan 18 23:57:30 UTC 2006


 I'm not exactly sure if this is a dev problem, but here goes. I
downloaded the latest SVN and compiled it in my old environment (same
machine, 32-bit PVR-500) and it works great. I decided that I would try
to go to 64-bits again (same machine) and finally try to get the HD3000
card that's been sitting on my shelf for 6 months to work. So I get
everything compiled just fine in 64-bits, grab the newest kernel because the HD3000 drivers are in the source. I can tune and
watch about half a dozen channels just fine using QAM. So I spent the
last two days working to get Myth functioning. Where I am at now is
mythtv-setup can scan the channels, it locks onto them and add them, but
when I go to view the channel, the front end spits out tons of:


2006-01-18 16:37:56.280 RingBuf(/mythtv//1864_20060118163747.mpg) Error:
Invalid file descriptor in 'safe_read()'


And so I check the files with mplayer and nothing, just a black screen.
The backend shows:


2006-01-18 16:46:41.279 adding: picard as a client (events: 0)

2006-01-18 16:46:41.289 TVRec(1): Changing from None to WatchingLiveTV

2006-01-18 16:46:42.563 DVB#0 DVB SI Table Parser Started

2006-01-18 16:46:42.718 Finished recording Unknown: channel 1864

2006-01-18 16:46:42.750 Finished recording Unknown: channel 1864

0: start_time: 5859.060 duration: -9223372036854.775

stream: start_time: 65100.668 duration: -9223372036854.775 bitrate=0

2006-01-18 16:46:46.052 AFD: Opened codec 0x2aaab1b034e0, id(MPEG2VIDEO)

2006-01-18 16:46:46.052 NVP: Disabling Audio, params(-1,-1,-1)

2006-01-18 16:46:46.052 AFD: Initializing audio parms from audio track

2006-01-18 16:46:46.053 AFD: Audio format changed

                        from id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps

                        to   id(NONE)    -1Hz -1ch   0bps    ; id(NONE)
-1Hz -1ch   0bps

2006-01-18 16:46:46.053 NVP: Disabling Audio, params(0,-1,-1)

2006-01-18 16:47:13.910 TVRec(1): Changing from WatchingLiveTV to None

2006-01-18 16:47:14.117 Finished recording Unknown: channel 1864

2006-01-18 16:47:41.755 Running HouseKeeping


Not sure where to go from here. Any ideas? By the way, I haven't even
messed with the PVR-500. I want to get the HD3000 squared away first
before messing with ivtv drivers.


System - Dual Xeon Hyper Threaded 2.8Gz, HD3000, Nvidia GeForce 6600,
Debian sarge amd64 vanilla kernel. SVN 8644.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20060118/53f03db5/attachment.htm

More information about the mythtv-dev mailing list