[mythtv] OSD problems: chromakey doesn't fade out; others don't do HD switch

Daniel Kristjansson danielk at cuymedia.net
Mon Feb 27 01:34:38 UTC 2006

On Sun, 2006-02-26 at 06:26 -0500, Wendy Seltzer wrote:
> The chromakey OSD is no longer fading from the screen after an item is
> displayed in TV playback, despite DB settings (particularly annoying
> when "Default Settings" comes up on playback), but takes an ESC press
> to remove.  Other OSDs still fade, so I'm guessing the problem might
> be <http://cvs.mythtv.org/trac/changeset/9072>.  This happens on
> playback of content recorded as MPEG4 or ATSC MPEG2.
> (I first noticed it at rev 9148, and still see the problem on 9152.)
Can you try reverting to 9071, and if the problem is gone there, try
9072? If that is the problem changeset this should be fairly easy to
fix. Any chromakey problems should be added to the #512 ticket. I plan
to work on the chromakey OSD a bit more in a couple weeks, and will be
referencing that ticket for problems to address.

> I switched to the chromakey after finding I could no longer tune
> LiveTV to the HD-3000 card input with other OSDs.  When I'd switch
> card inputs, I'd get a black screen for a long time, no signal
> monitoring, and then a return to the TV menu.  HD scheduled recordings
> would still record fine and playback fine.  With chromakey OSD, the
> signal monitoring comes up and the channel shows in LiveTV.
This sounds like a separate problem from the Chromakey OSD problems.

> NVIDIA 5200,  driver v1.0-7664
> XV, no XvMC
> Twinview displaying TV on second screen
> nothing in the non-myth setup has changed since an earlier, pre-0.19
> rev worked with HD, LiveTV, and non-chromakey OSD.
> (I've always gotten the message: VideoOutputXv Error: Couldn't get the
> color key color, probably due to a driver bug or limitation. You might
> not get any video, but we'll try anyway.
> but it's never previously affected playback.)
This means you can't use Chromakey OSD. It might be a setup problem, see
the #512 ticket for the xorg setting you need to set. I'm also not sure
the 7664 driver works with the Chromakey OSD, I'm using 6629. Also, I
find that I can only use chromakey on the first monitor in a twinview
setup, you should be able to force the driver to make your second
monitor the first monitor but still keep the left right ordering
correct. The OSD still shows up on the second display, but there is
a lot of blue screen blinking and other problems.

-- Daniel

More information about the mythtv-dev mailing list