[mythtv] schema upgrade 1108 to 1123 fails

M. Barnabas Luntzel mark at luntzel.com
Thu Feb 23 08:10:27 UTC 2006

On Feb 22, 2006, at 7:05 PM, Christian Hack wrote:

>>> the DB schema upgrade fails. as far as I can tell it is
>> trying to add
>>> the "generic" column twice. I deleted it by hand, tried to start
>>> mythbackend, then got the same error, but the column was replaced in
>>> the table.
>>> this is an upgrade from 0.18.1, using Atrpms packages. kernel is
>>> 2.6.15-1.1831_FC4, i386
>>> I've been over this with the ATRPMS list, as well as gotten no
>>> replies from mythtv-users. Blayne Cook is also reporting the same
>>> error.
>>> is it possible that it cannot go from schema version 1108 to 1123?
> I'd bet you've been playing with databases or SVN or something. I  
> upgraded
> via Atrpms from 0.18.0 (I assume this since my DB is started at  
> 1087 and
> went all the way through 1108 to 1123 without a hitch. See attached  
> log.
> CH
> <UpgradeLog.txt>
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

I wish I had it so easy...but this was a pure ATRPMs installation.  
I'm one of two people (that I know of) that had this happen, so I  
dunno. been wanting to avoid totally burning my database.

your situation is not precisely the same as mine. I'm going to take a  
chainsaw to dbcheck.cpp and see if I cant make it go.

More information about the mythtv-dev mailing list