[mythtv] schema upgrade 1108 to 1123 fails

M. Barnabas Luntzel mark at luntzel.com
Wed Feb 22 15:22:38 UTC 2006

the DB schema upgrade fails. as far as I can tell it is trying to add
the "generic" column twice. I deleted it by hand, tried to start
mythbackend, then got the same error, but the column was replaced in
the table.

this is an upgrade from 0.18.1, using Atrpms packages. kernel is
2.6.15-1.1831_FC4, i386

I've been over this with the ATRPMS list, as well as gotten no  
replies from mythtv-users. Blayne Cook is also reporting the same error.

is it possible that it cannot go from schema version 1108 to 1123?

on mythbackend startup:

2006-02-13 08:34:36.487 Using runtime prefix = /usr
2006-02-13 08:34:36.518 New DB connection, total: 1
2006-02-13 08:34:36.526 Connected to database 'mythconverg' at host:
2006-02-13 08:34:36.532 Current Schema Version: 1108
2006-02-13 08:34:36.537 Newest Schema Version : 1123
2006-02-13 08:34:36.541 New DB connection, total: 2
2006-02-13 08:34:36.544 Connected to database 'mythconverg' at host:
2006-02-13 08:34:36.548 Setting Lock for Database Schema upgrade. If
you see a long pause here it means the Schema is already locked and
is being upgraded by another Myth process.
2006-02-13 08:34:36.553 New DB connection, total: 3
2006-02-13 08:34:36.556 Connected to database 'mythconverg' at host:
2006-02-13 08:34:36.562 Upgrading to schema version 1109
2006-02-13 08:34:36.580 DB Error (Performing database upgrade):
Query was: ALTER TABLE oldrecorded ADD COLUMN generic TINYINT(1)
Error was: Driver error was [2/1060]:
QMYSQL3: Unable to execute query
Database error was:
Duplicate column name 'generic'
new version: 1109
2006-02-13 08:34:36.584 Database Schema upgrade FAILED, unlocking.
2006-02-13 08:34:36.588 Couldn't upgrade database to new schema 

More information about the mythtv-dev mailing list