[mythtv] [mythtv-commits] Ticket #1340: playback halts during LiveTV at end of show from remote frontends

Tom Lichti tom at redpepperracing.com
Mon Feb 20 18:01:35 UTC 2006

Isaac Richards wrote:
> On Sunday 19 February 2006 21:27, Tom Lichti wrote:
>> That's sort of what I thought. There seems to be a notification but it
>> came after I tried exiting. Will do on the logs.
> If it's just the frontend not getting the notification message that there's a 
> new file available, I've added a few lines of code (part of r9059) that 
> should fix it.
> Isaac
The reason I said that was because in the log I posted, it appears that 
the frontend is getting the message after I hit ESC to exit live 
recording, as if it was queued to be read, but was blocked by something:

2006-02-19 18:16:11.717 Ignoring livetv eof in decoder loop
2006-02-19 18:16:11.769 Ignoring livetv eof in decoder loop
2006-02-19 18:16:11.800 TV: StopStuff(): stopping player[s] (1/2)   
<---------------- I think this is when I hit ESC
2006-02-19 18:16:11.801 TV: StopStuff(): stopping recorder[s]
2006-02-19 18:16:11.807 NVP: Waiting for prebuffer.. 9 
2006-02-19 18:16:11.821 NVP: Exited decoder loop.
2006-02-19 18:16:11.834 LiveTVChain(live-htpc-2006-02-19T14:26:02): 
ReloadAll(): Added new recording  <------------- this looks like the 
2006-02-19 18:16:11.834 Resyncing position map. posmapStarted = 0 
livetv(1) watchingRec(0)
2006-02-19 18:16:11.891 Position map filled from DB to: 3573

I am recompiling with your fix, I'll let you know if it still occurs.



More information about the mythtv-dev mailing list