[mythtv] Unable to get ./configure to enable firewire or lirc with svn

Gene Stapp genestapp at gmail.com
Mon Aug 7 20:25:44 UTC 2006

I asked on the Users mailing list first about 2 to 3 weeks ago and got 
no helpful answers so I thought I'd repost this here with updated 

I am having problems configuring svn. I have tried just about everything 
to get firewire and lirc to enable under the mythtv directory 
./configure script. My full configure script for the svn and the mythtv 
folder is:

    ./configure --prefix=/usr/local --arch=nocona --enable-proc-opt
    --enable-dvb --dvb-path=/usr/include --enable-firewire --enable-lirc
    --enable-opengl-vsync --enable-v4l --enable-ivtv

I have tried double checking to make sure all the required libraries are 
there. Currently according to smart gui I have these versions of the 
files. I can't find any log that tells me why they won't enable, and I 
havn't found a command to give me a verbose output for the configure 
command  --verbose didn't work

myth svn ver: 10699 from 8-07
my kernel version: 2.6.17-1.2145_FC5 x86_64
running on Fedora Core 5
processor: intel 830 dualcore

required files for compile (from yum search command)
for firewire
libraw1394-devel.x86_64                  1.2.1-1.fc5            installed
libraw1394.x86_64                         1.2.1-1.fc5            installed
libraw1394.i386                          1.2.1-1.fc5            installed
libavc1394-devel.x86_64                  0.5.1-2.2              installed
libavc1394.x86_64                         0.5.1-2.2              installed
libiec61883.x86_64                       1.0.0-10.fc5.2         installed
libiec61883-devel.x86_64                 1.0.0-10.fc5.2         installed

for lirc
lirc.x86_64                              0.8.1-cvs20060628_60.r installed
lirc-devices.noarch                      0.7.0-1.rhfc5.at 
<http://0.7.0-1.rhfc5.at>       installed
lirc-kmdl-2.6.17-1.2145_FC5.i686         0.8.1-cvs20060628_60.r installed
lirc-lib-devel.x86_64                     0.8.1-cvs20060628_60.r installed
lirc-lib.x86_64                    0.8.1-cvs20060628_60.r installed

Any ideas on how I should proceed with this? When I ignore these not 
being configured, the qmake and make command works fine and everything 
works (minus the firewire and lirc)

More information about the mythtv-dev mailing list