[mythtv] Question about BACKEND_MESSAGE and ASK_RECORDING

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Mon Sep 5 20:02:34 UTC 2005

I thought i should implement support for handling the BACKEND_MESSAGE events
from the backend in my windows filters.
But i ran into some problems with the event ASK_RECORDING.
There must be something i've missed or overlooked.

The way i've implemented it is with a separate connection to the backend
that's handled by a thread.
This thread is able to recive events like SCHEDULE_CHANGE,
RECORDING_LIST_CHANGE, DONE_RECORDING and so on properly, but not

What happends when i have livetv going and a recording is about to start is
that i get something like this sequence of backend messages:
BACKEND_MESSAGE[]:[]SIGNAL 1[]:[]Signal Lock[]:[]slock 1 0 0 1 0 1 1
Is there something special about ASK_RECORDING ?
I thought all BACKEND_MESSAGE:s was sent to all playback sockets that did
"ANN Playback hostname 1" with the last number as a 1.

There must be something i've missed since it's obviously working with the
frontend, it gets the ASK_RECORDING message properly and shows the message
asking you what to do.
(if i don't do anything on the frontend when that happends it segfaults once
the timout occurs, but that's a different problem)

While i was debugging this i enabled network logging on the backend.
Why is the frontend continusly sending QUERY_PIXMAP_LASTMODIFIED for the
item that's selected in the Watch recordings screen?
It is the small preview pixmap of the recording it asks for right?
It's not like the pixmap is going to change right?
It looks like the messages arrive at about 2 times per second.

More information about the mythtv-dev mailing list