[mythtv] DVD rip crash

Robin Gilks g8ecj at gilks.org
Fri Oct 21 10:09:33 UTC 2005


Having just rebuilt from SVN (7535) I'm getting a problem when reading a
DVD. Is this just me? I can pull the ISO from the disk OK but using any of
the options that require delving into the VOB causes no data to be read
and as far as I can see mtd crashing out due to no data being available to
transcode (although that scenario is a guess)

This is what mtd reports:

zeus ~ # /usr/local/bin/mtd
2005-10-21 22:59:09.280 Using runtime prefix = /usr/local
2005-10-21 22:59:09.325 New DB connection, total: 1
mtd started at Fri Oct 21 22:59:09 2005
mtd is running on a host called zeus
22:59:09: Waiting for connections/jobs
22:59:09: mtd is listening on port 2442
libdvdread: Using libdvdcss version 1.2.8 for DVD access
22:59:11: DVD inserted: AU_103539
22:59:11:             : Title 1 is of type 8 (dvdinput table)
22:59:11:             : Title 2 is of type 8 (dvdinput table)
22:59:11:             : Title 3 is of type 8 (dvdinput table)
22:59:11:             : Title 4 is of type 8 (dvdinput table)
22:59:22: a client socket has been opened
22:59:31: launching job: job dvd 2 1 11 0 -1 /mnt/videos/AU_103539 - Title 2
2005-10-21 22:59:31.171 New DB connection, total: 2
22:59:31: transcode command will be: transcode -i /tmp/mythdvd/AU_103539 -
Title 2/vob/ -g 720x576 -f 0,3 -M 1 -V -B 1,0 -y xvid -w 1618 -o
/mnt/videos/AU_103539 - Title 2.avi --print_status 20 --color 0

Have I got a crap libdvdread (I've tried rebuilding it) or what else could
be happening - I assume that since I'm running mtd as root there won't be
a permissions problem and it all worked fine up to about 4 weeks ago when
I last tried it (but I've rebuilt from SVN several times since).

Any directions on getting better info to the list would be appreciated.

P.S. I'm running Gentoo stable so a library somewhere may have changed
during an emerge update...

Robin Gilks

More information about the mythtv-dev mailing list