[mythtv] Re: Ticket #459: Wrong Default Aspect when HD in 1920x1088

Greg Grotsky spikeygg at gmail.com
Sat Oct 15 17:32:21 UTC 2005

Answers below...

On 10/15/05, Daniel Kristjansson <danielk at cuymedia.net> wrote:
> I think this is narrow enough, my guess is 7334. It looks like
> it is not a change in the aspect ratio code giving you problems,
> but rather a change in the starting video due to the signal
> monitoring dummy video. The video output code should be adjusting
> to aspect ratio changes, but it appears it is not.
> This only happens in LiveTV right?

Yup, only live TV... the recordings from both channels displays correctly.

A little more detail should allow me to hone in on the problem.
> So...
> * Do you use any aspect override setting? (what is it?)
> (It looks like this is not applied on input change.)

I don't use any aspect override settings.

* Do you use display resizing support?
> * If so what are the overrides?
> (w/all details, including aspect ratio overrides of course).

I use the "Seperate video modes for GUI and TV playback option if that's
what you mean. I only use it to force myth into displaying the videos in a
16:9 aspect ratio. I use these settings:
GUI: 1920x1080 and Video Output: 1920x1080 Rate: Any and Aspect: 16:9
The Overrides for specific video sizes are all zeroed out, I want all my
videos scaled up to 1920x1080.

* What is the resolution and aspect ratio of a channel giving
> you problems?
> * Are there any letterbox bars? left/right or top/bottom?

The resolution of the problem channels is 1920x1088 (should be 16:9 with 8
lines of overscan?), I have a channel in 1920x1080 and it works fine. When
entering liveTV while the tuner is tuned to the problem channel, it will
randomly choose bars on the top/bottom or left/right. I haven't found a
rhyme or reason about how it chosen.

* Does this problem occur if you start on that channel?

* If it occurs when you switch from another channel,
> what are the attributes of that previous channel?
> (resolution, aspect ratio, letterbox, etc.)

It happens both if I enter LiveTV with the problem channel tuned or if I
change from another channel to the problem channel. The attributes vary:
704x480, 720x480, 1280x720, 1920x1080.
>From any of these resolutions to 1920x1088 and the problem channels have the
aspect ratio issue.

* Can you remedy the problem by changing the letter-boxing?
> * If yes, from what? to what?

I can fix it by cycling through the aspect ratios on the fly using 'W'
(toggle aspect). The default is set to "Off", as I said, but if I cycle
through them 16:9, Fill, and Off will all look correct. It will cure the
issue if I cycle all the way through to "Off" again.

Hope this points out the problem. Let me know if you need more info!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20051015/cad38c76/attachment.htm

More information about the mythtv-dev mailing list