[mythtv] svn 7441: No errors, but file not created?

Glen Dragon gad at jetcom.org
Tue Oct 11 05:37:53 UTC 2005

Daniel Kristjansson wrote:

>On Mon, 2005-10-10 at 19:26 -0600, John P Poet wrote:
>>Everything compiled fine, and mythbackend started up just fine. 
>>However, when it went to record a show, no file was created.  The
>>backend log shows no errors, and indicates that it started the record
>>process just fine:
>It doesn't create a file until the recorder has started.
>And it doesn't start an ATSC recorder until it has seen the
>MGT, VCT, PAT, and PMT. It looks like it got a signal lock,
>but then never saw any of these tables it needs for a channel
>lock. The only change from 7267 is that it no longer times
>out on scheduled recordings, this is by request from the UK
>where channels go off-air and on-air frequently.
>But that shouldn't have caused any problem, perhaps it was
>a fluke that it happened with the latest version? Can you
>try repeating it? If it is repeatable, finding the check-in
>that caused it might narrow in on the problem.

I've also seen this on a compile from early this evening.  It was on the 
slave tuner. Tried to record MNF, and baseball. baseball got the primary 
tuner, MNF tried to get the 2nd hd3000 on the slave be. Everything 
looked like it was working in the logs, but my eyes are not trained on 
all the new debug. The status said that the tuner was recording. Killing 
the slave BE, the master nicely re-sceduled the tuning for the 3rd tuner 
(on the master), and all worked great.

I've seen this case one other time about 2 weeks ago.  restarting the 
BE, retuned, and it worked.   Seems to be an intermittent glitch.

I'll dig though the logs tomorrow, and see if I can find the spot.  I'll 
look for the (4)? magic tables in addition to the the signal lock.

More information about the mythtv-dev mailing list