[mythtv] DVB issues with r7369

Adam Egger mythtv2005 at bdam.de
Mon Oct 3 14:50:00 UTC 2005

On 10/3/05, Daniel Kristjansson <danielk at cuymedia.net> wrote:
> On Sat, 2005-10-01 at 15:30 +0200, Adam Egger wrote:
> > Hi,
> >
> > I still have a few issues with the latest build (r7369, dvb-t,
> > debian64, Germany). I'll attach a log where all the problems should be
> > included:
> >
> > 1. The channel it first tuned to wasn't set to fullscreen. I'm
> > sometimes seeing it, that some channels are set to 16:9 instead of
> > fullscreen, then I have to manually change to fullscreen.
> I haven't touched this code in VideoOutput, but this probably has
> to do with some heuristic not being applied on aspect ratio changes
> which is applied when the video starts with a specific aspect
> ratio. You now always start playing a dummy recording in live tv
> mode, so it may not have the same aspect ratio as the channel when
> it eventually comes in.

Ok, there seem to be still some issues left with DVB ratio. There's
just another thread in -dev about broken DVB ratio.

> > 2. After switching to the second channel the picture was great but a
> > few moments later appeared the message "You should have gotten a Lock"
> Give 7376 a try.

Great :)

> > 3. There is a additional channel I can see now on LiveTV (It's called
> > just -), it doesn't appear in the channel list. So I've tried to zap
> > to this strange channel (don't know if it appears in the backend log).
> Hmmm, I'll look into this. If you could figure out which commit caused
> this it might help a great deal...

I can browse through the list with 7300 (so it's possible to pass from
channel number 22 (the last one) to channel 1). With 7317 there's this
strange - channel which prevents going from channel 22 to 1. It's just
impossible to go through this black screen with channel number - ;)
With 7310-7314 I don't get a signal lock so I'm not sure if it also
appears there. When I try to browse without a lock I can't see the
additional channel.

> > 4. Then I left LiveTV and tried to immediatelly restart LiveTV. The
> > screen turned then black for a few seconds and it switched back to the
> > main menu. Frontend shows:
> > 2005-10-01 15:24:08.097 LiveTV not successfully started
> This looks like the problem Jon Whitear is experiencing. He
> can't repeat it in gdb. But perhaps you can. If so just hit
> Ctrl-C when the backend stops responding and send me the
> logs + the output of "thread apply all bt".

I'll check if it still happens.

Thank you,

More information about the mythtv-dev mailing list