[mythtv] Mythtv Configure Failure

Eric Bosch eric.bosch at comcast.net
Mon Nov 21 19:09:11 EST 2005

I am running Gentoo Linux 2005.1 w/updates, and after my last update
(rsync) and I attempt to execute configure --prefix=/usr
--enable-opengl-vsync --enable-lirc, it fails to enable lirc support. 
It worked fine prior to updating the system day before yesterday.  I
tracked the problem to configure script, beginning on line 1980:

cat > $TMPC << EOF
#include <lirc/lirc_client.h>
int main( void ) { return 0; }

    if $cc $CFLAGS $ARCHFLAGS -o $TMPE $TMPC 2> /dev/null ; then

where it should create a file and place the header info in the file. 
This is the point of failure, the file named in $TMPC is not being
created, thus the feature fails.  Can anyone help me resolve this
issue?  I  have worked through the script, and echoed the contents of
$TMPC, finding it to contain "/tmp/ffmpeg-{Random Nbr}.c, but the file
is not created.  Permissions do not seem to be of issue, its just the
cat expression seems to do nothing.  Thanks!

More information about the mythtv-dev mailing list