[mythtv] Odd performance problems with latest CVS

Todd Tidwell artist at wildstar.net
Tue Mar 22 01:20:23 UTC 2005

Hey gang,

So I upgraded last night to the latest CVS.  Happily, everything compiled
and went generally well.  I was waiting excitedly to see some of the patches
since the .17 release and had been putting of moving to CVS (which is my
usual code-level) until a couple of patches made it in so I could be lazy
and not have to apply them by hand.

I ran into a few problems, and I'd like some input:

1) Previous to moving to this version, my HDTV recordings played smoothly
without XvMC or libmpeg support turned on.  Now I have to used XVMC to even
play them back smoothly

2) Sadly, XVMC has some issues:  IT plays smoothly and does not cause any
crashing of the frontend as it did on the .17 release (for me) but anytime
*any* text or OSD stuff is on the screen it jumps like *crazy* until the
OSD/text goes away.

3) During the initial install I had problems with the database upgrade in
that I had already applied Jim Westfall's patch for the firewire connection
broadcast stuff and then the latest CVS tried to add the
"firewire_connection" column a second time. (Easily fixed) and even though
after I resolved that issue the DB was "successfully" upgraded, mythbackend
would not schedule programs due to program.manualid and recording.manualid
being missing.

Just thought someone should know and that I'd ask and see if there were any
short-term solutions...


More information about the mythtv-dev mailing list