[mythtv] mythepg fails to compile

Hamish Moffatt hamish at cloud.net.au
Tue Mar 8 21:21:42 UTC 2005

On Tue, Mar 08, 2005 at 07:47:27PM +0100, Adam Egger wrote:
> I'm trying to compile myth on debian64 (with gcc3.4). I'm getting this error:
> g++  -o mythepg main.o    -L/usr/share/qt3/lib -L../../libs/libmyth
> -L../../libs/libmythtv -L../../libs/libavcodec
> -L../../libs/libavformat -lmythtv-0.17 -lmythavformat-0.17
> -lmythavcodec-0.17 -lmyth-0.17 -lfreetype -lmp3lame -L/usr/X11R6/lib
> -lXinerama -lXv -lXxf86vm -lqt-mt -lXext -lX11 -lm -lpthread
> ../../libs/libmyth/libmyth-0.17.so: undefined reference to
> `__gnu_cxx::__exchange_and_add(int volatile*, int)'
> ../../libs/libmythtv/libmythtv-0.17.so: undefined reference to
> `std::_Rb_tree_decrement(std::_Rb_tree_node_base*)'

> Is it gcc-3.4 related or is it an error on debian64?

I think I saw this when I mixed g++-3.4 and -3.3 during compile

Usually /usr/bin/g++ on Debian (even amd64) is 3.3. Did you change the
symlinks to point at 3.4? Did you change all of them?

Hamish Moffatt VK3SB <hamish at debian.org> <hamish at cloud.net.au>

More information about the mythtv-dev mailing list