[mythtv] can't find -lavc1394

Carl Reynolds mythtv-dev at hyperbole-software.com
Wed Jun 29 20:57:17 UTC 2005

I decided I wanted to try to compile MythTV.

I downloaded mythtv-0.18.1.tar.bz2 from mythtv.org

created a directory called 'mythtv' and extracted the tar ball in it.

# ./configure
# qmake mythtv.pro
# make

This is where I ran into problems. When the make got to libmyth it 
aborted with the message
   cannot find -lavc1394

I searched my system for libavc1394 and found it installed in /usr/lib64

I've tried a number of things to get libmyth to compile including 
re-installing libavc1394, and compiling libmyth without -lavc1394 in the 
Makefile. Nothing has helped.

Would someone please suggest what I should do next to get  MythTV to 
compile on my machine?


Following is the output from a number of commands on my system including 
the error message from making:

# make
make[2]: Entering directory `/root/mythtv/src/mythtv/libs/libmyth'
rm -f libmyth-0.18.1.so.0.18.1 libmyth-0.18.1.so libmyth-0.18.1.so.0 
g++ -shared -Wl,-soname,libmyth-0.18.1.so.0 -o libmyth-0.18.1.so.0.18.1 
dialogbox.o lcddevice.o mythcontext.o mythwidgets.o oldsettings.o 
remotefile.o settings.o themedmenu.o util.o mythwizard.o uitypes.o 
xmlparse.o mythplugin.o mythdialogs.o audiooutput.o inetcomms.o 
httpcomms.o mythmedia.o uilistbtntype.o uiphoneentry.o generictree.o 
managedlist.o DisplayRes.o volumecontrol.o volumebase.o 
audiooutputbase.o dbsettings.o screensaver.o screensaver-null.o output.o 
langsettings.o mythdbcon.o audiooutputnull.o DisplayResScreen.o 
util-x11.o qmdcodec.o audiooutputoss.o mythcdrom.o mythmediamonitor.o 
mythcdrom-linux.o audiooutputalsa.o jsmenu.o jsmenuevent.o 
screensaver-x11.o DisplayResX.o moc_dialogbox.o moc_lcddevice.o 
moc_mythcontext.o moc_mythwidgets.o moc_settings.o moc_themedmenu.o 
moc_mythwizard.o moc_uitypes.o moc_mythdialogs.o moc_inetcomms.o 
moc_httpcomms.o moc_mythmedia.o moc_uilistbtntype.o moc_uiphoneentry.o 
moc_managedlist.o moc_mythcdrom.o moc_mythmediamonitor.o moc_jsmenu.o  
-L/usr/lib64/qt-3.3/lib -L../libmythsamplerate -lmythsamplerate-0.18.1 
-L../libmythsoundtouch -lmythsoundtouch-0.18.1 -lfreetype -lmp3lame 
-lasound -lraw1394 -L/usr/lib64 -lavc1394 -liec61883 -L/usr/X11R6/lib64 
-lXinerama -lXv -lXxf86vm -lqt-mt -lXext -lX11 -lm -lpthread
/usr/bin/ld: cannot find -lavc1394
collect2: ld returned 1 exit status
make[2]: *** [libmyth-0.18.1.so.0.18.1] Error 1
make[2]: Leaving directory `/root/mythtv/src/mythtv/libs/libmyth'
make[1]: *** [sub-libmyth] Error 2
make[1]: Leaving directory `/root/mythtv/src/mythtv/libs'
make: *** [sub-libs] Error 2

# uname -a
Linux amethyst 2.6.11-1.35_FC3 #1 Mon Jun 13 00:59:03 EDT 2005 x86_64 
x86_64 x86_64 GNU/Linux

ls -l /usr/lib64/libavc1394*
lrwxrwxrwx  1 root root    19 May 16 16:13 /usr/lib64/libavc1394.so.0 -> 
-rwxr-xr-x  1 root root 17168 May 15 16:46 /usr/lib64/libavc1394.so.0.2.0

# rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" libavc1394tv]# 
rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}" libavc1394


More information about the mythtv-dev mailing list