[mythtv] Mythtv-0.18.1 on AMD64

Hanno 'Rince' Wagner wagner at rince.de
Wed Jun 22 07:04:56 UTC 2005


I just tried to compile mythtv-0.18.1 on AMD64 (Debian-based
system). This worked quite fine with previous versions of MythTV
after installing a patch which tweaked RingBuffer.(cpp|h).
Unfortunately, there seem to be more changes this time; the compile
process stops in compiling libavcodec:

crystalball:~/src/mythtv/mythtv-0.18.1# make
cd libs && make -f Makefile
make[1]: Entering directory `/root/src/mythtv/mythtv-0.18.1/libs'
cd libavcodec && make -f Makefile
make[2]: Entering directory
gcc-3.4 -c -pipe -w -O3 -fomit-frame-pointer -D_REENTRANT -DPIC
-DQT_THREAD_SUPPORT -DQT_SHARED -I/usr/share/qt3/mkspecs/default -I.
-I.. -I../.. -I/usr/include/qt3 -o mpegvideo.o mpegvideo.c
mpegvideo.c: In function `ff_copy_bits':
mpegvideo.c:4345: error: extended registers have no high halves
{standard input}: Assembler messages:
{standard input}:15144: Error: bad register name `%'
make[2]: *** [mpegvideo.o] Error 1

Has anyone seen this before and has maybe already a patch so I can
compile mythtv-0.18.1 under AMD64? I am also willing to test patches
with that architecture.

Linux crystalball 2.6.10 #1 Mon Feb 7 22:28:36 CET 2005 x86_64 GNU/Linux
model name      : AMD Athlon(tm) 64 Processor 3500+

(used is gcc-3.4, but there are no other results with gcc-4.0 or

Ciao, Hanno
|  Hanno Wagner  | Member of the HTML Writers Guild  | Rince at IRC      |
| Eine gewerbliche Nutzung meiner Email-Adressen ist nicht gestattet! |
| 74 a3 53 cc 0b 19 - we did it!          |    Generation @           |
Fachbegriffe der Informatik : Deadlock
->  Einsperren des Admins im Serverraum.
Manfred Worm Schäfer

More information about the mythtv-dev mailing list