[mythtv] Realtime Commercial Flag / skip problem

Lucas Meijer lucas at mach8.nl
Mon Jun 13 21:56:04 UTC 2005


ben levitt wrote:
> On 6/13/05, James Armstrong <james at thearmstrongs.org> wrote:
> 
>>I am running CVS as of a week ago. I have been using the realtime
>>flagging since it came out but have not had any luck. Last night I
>>started to watch The Deadzone as it was being recorded. At the first
>>commercial the osd popped up and showed a commercial skip, but when I
>>pressed skip it osd showed 'Not Flagged'. Near the end of the recording
>>the last commercial skip worked. This was just a few minutes after the
>>recording stopped.
> 
> I wonder if you need to turn on the "Skip Unflagged Commercials"
> setting on the "Commercial Skip" settings screen?
> 
> And if you do need to turn that on, then maybe the code that checks
> that setting should be changed to allow commercial skip attempts in a
> program that hasn't been completely flagged, if that program's
> flagging has started, and realtime flagging is enabled?

This looks like a bug. THe "skip unflagged commercials" feature has been 
revoked in a recent commflag restructure. It used to do "as we go" 
skipping based on blank frame detection alone. The idea is that you now 
use the new realtime detection.

Which unfortunattely seems to have a problem. I know Chris (doing most 
commflagging work) has been working on the skipping of commercials 
recently (not so much the detection), so upgrading to current cvs might 
help out.

Bye, Lucas


More information about the mythtv-dev mailing list