[mythtv] Live TV not releasing tuners.

Keith Irwin kirwin at ncsu.edu
Sat Jun 11 02:02:54 UTC 2005

So, I went through the arduous, time consuming task of stepping through 
the last several days' worth of commits.  The result of this process is 
to discover that none of them caused it.  It appears to be some problem 
with CVS, dependencies, or both.

When I did a completely clean check-out and build in a new and 
untouched directory, everything worked out (well, everything mostly 
worked okay, there are now some QAM channels which I can't watch in 
Live TV mode even though they record fine.  Oddly enough, those worked 
in my old cvs directory until the last update and even with the last 
update).  My advice to Matt would be to try the same thing.  We 
probably got in the same situation somehow.

There seem to be dependencies which are not there which need to be.  
Specifically, when I did some of the check outs or other changes which 
should have resulted in some things getting rebuilt did not.  When I 
get some time, I'll try to track them down and add them.  Perhaps that 
will fix things in the future.  For the moment, redoing from scratch 
when odd problems occur is probably a good safety measure.


More information about the mythtv-dev mailing list