[mythtv] cvs AMD64 compilation - mpegvideo.c error unrecognizable insn

Eric STEIMER steimer at club-internet.fr
Tue Feb 8 13:19:45 UTC 2005

Eric STEIMER wrote:
> Paul Barrette wrote:
>> Eric,
>> I have amd64 gentoo, I had to disable mmx, I noticed you have it
>> turned on.  I don't know if this is fixed yet, but since no one else
>> has responded, I thought I would mention it.
>> --disable-mmx or turn it off in the mythtv.pro file, can't remember now.
>> Pb
> Yes, I tried that already (using ./configure --disable-mmx). That didn't 
> do the trick, and I got quite the same result:
> mpegvideo.c: In function `select_input_picture':
> mpegvideo.c:2112: error: unrecognizable insn:
> (insn:HI 1640 1639 863 84 0x2a97227ae0 (set (reg:SI 291)
>     (plus:SI (mult:SI (reg:SI 291)
>         (const_int 2 [0x2]))
>     (reg:SI 291))) -1 (insn_list 1639 (nil))
>     (nil))
> mpegvideo.c:2112: internal compiler error: in extract_insn, at recog.c:2175
> Thanks anyway Paul.
> Eric
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

OK, solution :)
PB came from the arch designated as the compilation reference.
I applied Ian's patch (see [mythtv] [PATCH] mythtv/settings.pro lists 
wrong proc type for amd64) to declare the k8 architecture.
I also had to change sym link of gcc/g++/(gccdebug) to the 3.4 versions, 
and eventually the compilation went smooth. =)
Side note : I ran the 'make distclean' command to clear a pb with 
libqt.prl with my first attempt.

Now I'm quite pleased to report that compilation does fine on Debian 
AMD64 pure64 (alioth).

More information about the mythtv-dev mailing list