[mythtv] Broken AV sync after mythtranscode

Geoffrey Hausheer mythtv0368 at phracturedblue.com
Thu Dec 22 14:11:40 EST 2005

On 12/22/05, Steve Adeff wrote:
> there are some win32 apps that do similar to what ProjectX does in fixing
> streams, though what ProjectX is really good at is fixing A/V sync issues in
> mpeg files, from what I've read by people in "the know", its an uncanny
> ability....
The program is not magic.  It only has PTS and DTS info to go by. 
mythtranscode can fix some types of A/V issues (missing/broken Video
frames), but not others (broken/missing audio frames).  Doing so is
possible (to some extent), but I haven't coded it yet.  However, I
don't plan to reproduce a full-fledged video editor in this tool.

None of that has much to do with what is going on here though.  I need
a test case that I can use to even see the problem, and enough info to
understand exactly what users are experiencing and where.  In the
cases that I've seen, there is a backwards jump in the PTS (which is
certainly broken), but mplayer seems to compensate appropriaetly, so I
don't see any evidence of a significant A/V distontinuity.  As the
problem is there in the original, mythtranscode shouldn't make
anything worse. I'll be happy to try and fix anything I can reproduce.
 To that effect, I need a stream to work on, as I haven't seen this
happen with any of the files in my collection.

And to answer your question, no mythtranscode doesn't use projectX and
never will (unless someone else decides to usurp ownership of it). 
Conversation about it belongs on the users list (if anywhere), and
just serves to derail any useful conversations about things I actually
CAN fix.


More information about the mythtv-dev mailing list