[mythtv] Should mythtranscode be preserving closed-captioning data?

f-myth-users at media.mit.edu f-myth-users at media.mit.edu
Thu Dec 8 18:01:35 EST 2005

    Date: Thu, 08 Dec 2005 16:24:47 -0500
    From: Daniel Kristjansson <danielk at cuymedia.net>

    On Thu, 2005-12-08 at 16:06 -0500, f-myth-users at media.mit.edu wrote:
    >     Date: Thu, 8 Dec 2005 03:50:35 -0500
    >     From: Isaac Richards <ijr at case.edu>
    >     CC data from the pvr-x50 isn't supported.  These are users list questions.
    > Er, ok.  So why is there a UI element mentioning it in mythtv-setup?
    Because we record the captions or teletext so that old recordings will
    have them when in the future the frontend supports decoding them.

I don't (quite) understand this, since I turned on the switch but
the CC info wasn't saved (even after boot) until I went in directly
w/ivtvctl and enabled it (and that took effect instantly), but
whatever.  (This is running ivitv 0.4.0 & 0.4.1-r1, btw.)

[I'm recording in PS mode, since that's the default; I note that your
patch claims that TS mode is required, but don't know if that might
have changed the behavior above.]

    > (And is that why setting it seems to have no effect?)
    > Is such support contemplated at any point?
    Yes, see ticket #368.

Aha!  I missed this 'cause it doesn't mention "closed caption"
anywhere and I wasn't searching for teletext.  Thanks.

If this patch gets incorporated, there will probably be lots of
confused people unless MPEG4 transcoding supports it as well, though.
Otherwise their CC/teletext will appear while the episode is being
recorded and shortly thereafter, and then "vanish" when they look at
it again 'cause it got transcoded... :)

More information about the mythtv-dev mailing list