[mythtv] SVN issues

Daniel Kristjansson danielk at cuymedia.net
Fri Dec 2 19:34:56 UTC 2005

On Mon, 2005-11-28 at 20:46 +0100, Adam Egger wrote:
> Hi,
> I'm using r8070 on debian sid, kernel 2.6.14, DVB-t/de.
> I see some issues with it:
> 1. It always shows a strange duration and bitrate for all my recordings:
Don't know about this.

> 2. There's still the "Couldn't get the color key color" message :)
Nothing to worry about, if you see video. With colorkey capable XVideo 
adapters this indicates a serious error, but with adapters not capable
of colorkeying this just means the top and bottom edges of the video
may bob when bob-deinterlacing is used. This is a problem with the
latest nVidia adapters, and older nVidia adapters if you tell the 
driver to use OpenGL to simulate XVideo in xorg.conf. My only
recommendation is to try to avoid the 6xxx and 7xxx nVidia adaptors
if you can. I have a 6600 sitting in a box over here because it can't
drive my monitors at a high enough resolution and it doesn't support
chromakey; it's really sucky all around compared to the 5xxx series. :/

> 3. The backend log very often shows quite often:
> 2005-11-28 20:15:31.061 MainServer::HandleQueryRecordings()
>                         Couldn't find backend for:
>                         Unknown : "Unknown"
> What does it mean?
no idea

> 4. I'm very happy to have the "Delete LiveTV recordings after 7 days"
> because the realtime autoexpire absolutely doesn't work here. After
> zapping around for several minutes it only shows one expire message in
> the backend log:
In current SVN it should also hide the LiveTV recordings by default.

> 5. It takes now 8sec (!!) to open the "Program Details" screen (by
> pressing U). It's *much* slower now.
It's kinda slow here, but more like 1 second.
But I didn't even know about this feature before now.

> 6. There are some compile warnings in replex/multiplex.c:
And a few others, these aren't a huge priority because of the more serious
LiveTV problems. But if someone goes through the trouble of fixing them
and creates a patch ticket I'll review and commit it.

> 7. I also see the known frontend crash (should be caused by 687, which
> causes 689, which causes segv):
> 2005-11-28 20:08:52.156 AFD Error: Reset(): avformat err(-1) on
> av_open_input_file call.
The crash should be fixed now. The lack of data should be addressed soon.

> 8. The Program not found in PAT also happens for me:
Stuart Auchterlonie is looking at this.

-- Daniel

More information about the mythtv-dev mailing list