[mythtv] [exp. patch] xv xvmc merge (v3)

Robert Johnston anaerin at gmail.com
Thu Apr 7 19:50:10 UTC 2005

On Apr 7, 2005 1:33 PM, Daniel Kristjansson <danielk at cat.nyu.edu> wrote:
> Aran Cox wrote:
> > Before I noticed that you mention breaking HDTV support, I tried
> > applying this patch to CVS as of a few moments ago and got some
> > significant breakage in libs/libmythtv/videoout_xv.cpp.  I wanted to
> > try it because XvMC worked so much better with your v1 patch.
> Yep, I just broke it about an hour ago, I'm fixing it at the moment.
> If you checkout the previous version of videoout_xv.cpp then apply
> the patch the only reject is simple one in libmyth.pro
> > Also, is there some reason you didn't create a unfied diff patch
> > instead of the shell installer copying files, etc.?  I always have to
> > look it up (and just did again) but the option to treat missing files
> > as present but empty is -N.
> I'll try that. At some point at least -N didn't work with cvs diff.
> I have a script that generates my patches so it's not as if I go
> through the effort of manually creating the apply.sh script each
> time.
> > Another question, is any of this slated to go into 0.18 or is this
> > more of a 0.19 timeframe?
> 0.19, it will probably go in to cvs right after 0.18, assuming I get
> enough positive test reports and manage to fix all the bugs I know
> about by then.

Okay, the patch as of yesterday's CVS, is working great. No crashing.
But still jittering on OSD.

It seems that it will jitter when it's first shown, then stabilise
after 3 seconds or so, then after about 10 seconds start jittering
again. That could be something on my machine, but XvMC in 0.16 was
perfectly solid, and the only way you could tell you were using XvMC
was that the OSD was black and white.

What's been changed since 0.16 wrt OSD code?

More information about the mythtv-dev mailing list