[mythtv] Slave backend hang after ANN command

John Patrick Poet john at BlueSkyTours.com
Thu Apr 7 01:05:22 UTC 2005

Isaac Richards wrote:

>On Wednesday 06 April 2005 03:10 pm, Jason Gillis wrote:
>>>Try upgrading to current CVS and add a call to
>>>ProcessRequest(masterServerSock) at the end of the reconnectTimeout()
>>The addition of the ProcessRequest() call seems to have fixed it.  Adding
>>that as the last line in reconnectTimeout() has made it so that I can't
>>reproduce the problem anymore.  I had already pulled CVS about an hour ago,
>>and that hadn't helped this specific problem.
>>I was just about there on my own, as I was almost convinced that the OK
>>response and QUERY_FREESPACE request were coming in almost together.  My
>>thinking was that the readyRead() signal wasn't firing because the data
>>arrived long before the connect() call was made.
>Exactly what I was thinking. =)  I'll check it in to CVS shortly.
Unfortunately, the latest CVS does not fix the problem I have been 
seeing.  If I reboot my slave backend, I still get:

2005-04-06 18:57:50.057 Slave backend: jade has left the building
Mutex destroy failure: Device or resource busy
2005-04-06 18:57:50.060 Reschedule requested for id 0.

In my master backend log, and the master backend dies.

I will try and get a backtrace.


More information about the mythtv-dev mailing list