[mythtv] [PATCH] Reinitialize deinterlace filter on video change

Jarod Wilson jcw at wilsonet.com
Fri Sep 24 15:17:46 EDT 2004

On Friday 24 September 2004 11:11, Doug Larrick wrote:
> Jarod Wilson wrote:
> > The first thing that jumps out is you're using OpenGL sync, while my
> > system is one of those that gets badly hosed when I try to use OpenGL
> > sync.
> It shouldn't make a huge difference, unless of course there's a bug in
> whatever video sync method you're using.  Which one is it?

At present, RTC. I got similar playback with USleep busy wait though.

> > And it just dawned on me that I've rebuilt Myth a few times now, and
> > never chmod +s'd the frontend again. Maybe the one time I swear it played
> > back I had the suid bit set... chmod'ing now.
> Also shouldn't cause the magnitude of problems you're seeing.

I didn't think it should, but I'll give it a go. I also need to double-check 
what line I have that matches up with your:

2004-09-24 08:08:34 Interlaced: Progressive Scan  video_height: 720 fps: 

I know that before applying the patch at the beginning of this thread, I was 
seeing video_height: 720 fps: 29.97, not sure if that is still the case, but 
the video does look like its playing at half-speed. Definitely something to 
investigate when I get home...

Jarod C. Wilson, RHCE
jcw at wilsonet.com

Got a question? Read this first...
MythTV, Fedora Core & ATrpms documentation:
MythTV Searchable Mailing List Archive
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-dev/attachments/20040924/c44ec338/attachment.pgp

More information about the mythtv-dev mailing list