[mythtv] [PATCH] HDTV Recorder Patch

John Patrick Poet john at BlueSkyTours.com
Tue Nov 30 05:28:28 UTC 2004

Daniel Thor Kristjansson wrote:

>On Mon, 29 Nov 2004, John Patrick Poet wrote:
>]As I suspected, removing the VERBOSE did not fix the problem.  I still cannot
>]fastforward/rewind in any program recorded from my PBS station using your
>]hdtvrecorder.  The current CVS hdtvrecorder works fine with that channel.
>]Sorry about that....
>No need to apologize, it sounds like a genuine bug. Now from what you 
>told me before FF/RW does work while the backend is still recording the 
>program, right? So maybe it's a database problem? After the recording 
>finishes, does it not work at all, or just take a very long time?
>-- Daniel
While the show is actually recording, FF/RW do *not* work.  They 
actually cause the video to be played back *slower* than normal speed.  
"Skip ahead" sometimes works and sometimes has no effect -- almost like 
it depends on the current position in the show.  "Skip back", does move 
the position backwards but sometimes it is by 6 seconds, sometimes more, 
sometimes it moves all the way back to the beginning of the show.

Watching a show that is done recording does behave a little different.  
The "position" in the show always says "0:00 of 0:00".  The show will 
PLAY just fine, but....   "Skip forward" never works - it just continues 
to play from the current position.  FF/RW cause the video to freeze up 
with an eventual message telling me that I have "finished watching" the 
show.  "Saving" the position does not work.  If I try to save the 
position, then stop watching, when I start watching again, it always 
starts from the beginning.

Do you want me to create another sample clip?


More information about the mythtv-dev mailing list