[mythtv] LiveTV playback timing problems

Paul Sykes pdsykes at gmail.com
Fri Nov 26 17:42:36 UTC 2004


I am still having trouble with my mythtv setup regarding a timing
problem while watching livetv, I have included my original e-mail and
it has been suggested to me that it might be the result of a problem
with my soundcard being locked to 44.1khz when dvb signals are usually
at 48khz.

AMD Athlon XP 2100+
Soyo Dragon+ Via 266a chipset
512Mb PC2700 DDR RAM
Nvidia GeForce4 Ti 4200 128Mb Graphics Card
    Nvidia Kernel and GLX driver version 1.0.6629
60Gb DMA100 HDD (Ext3)
CMI PCI (Onboard) 8338 soundcard running alsa kernel drivers
Hauppauge Nova-T USB DVB tv device

Gentoo Linux, kernel 2.6.9-r4
MythTV CVS 0.16.20041115-1

I have tried playing with the RTC related kernel options and nothing
seems to fix the problem.  I did manage to track the original problem
of the video and sound being slow to RTC support in the alsa driver.  
This would suggest that my RTC clock is not accurate but I am not sure

I am currently using the SGL OpenGL video timing method in MythTv
which seems to work very well apart from the problem of the position
timer running slow.  Having not been involved in the development of
MythTV and still very new to both linux and mythtv I do not know what
MythTV uses as it's timing method, if somebody could tell me this
might help?

If anybody could give me any further insight in to the problem below I
would be most grateful.

Thank you again



I hope that this is the right list to send this message to, but I have
had no luck trying the users list.

I have a problem with the playback of my LiveTV on a Hauppauge Nova-T
USB.  The initial problem was that everything, both sound and video,
were played slowly.  This would mean that the current position of the
video stream would fall further and further behind as time progressed.
It would loose about 5 minutes every hour.

I have sort of fixed this with a mixture of recompiling the kernel
less various options and compiling a CVS version of MythTV.  I
eventually tracked it down to the enhanced real time clock option in
the kernel menuconfig.  Once I had removed this option it fixed the
video playing slowly.  Namely I suspect because the frontend stopped
using RTC and used a USleep method.

However, it did not entirely fix the problem.  Although I could watch
BBC News 24 and the clock on the screen would stay correct, the timer
telling you where you were in the LiveTV stream continues to fall
behind in time.  This is only a problem when I try and pause or skip
back in LiveTV, when I do this is skips from the position the timer
thinks it is in the livetv stream, and not where it actually is.

I have tried various kernel options, including HPET and nothing has
helped, all I know is that the video and sound both slow down when I
enable the enhanced real time clock option.

If anybody could help me I would be most grateful as it is a mildly
irritating bug.  If there is any advice on kernel options that may
help please could you let me know what they are.

If anybody knows what mythtv uses as a timer, ie. what the RTC and
USleep modes are then this may help solve the problem.  I would also
be willing to post my kernel configuration and full hardware list if
this would help.

Thanks in advance.


More information about the mythtv-dev mailing list