[mythtv] Re: Patch: Latest Audio Patch

Huang Tingjie tingjie at treblid.dyndns.org
Fri Nov 12 13:46:11 UTC 2004

 > I don't have the details as I am at work now and I can't remember the
 > error reported by mythmusic ( mythfronend quits saying mythmusic
 > plugin cannot find symbol VolumeControl, or is it VolumeBase?)
As a follow up to my previous email. I re-checkout'ed fresh copies of 
mythtv and mythmusic modules. Both compiled without problems now. But 
mythfrontend quit immediately and give me the same error message when I 
tried to run mythmusic. The error given was:
2004-11-12 21:01:32.048 Registering MythMusic Media Handler as a media 
/usr/local/bin/mythfrontend: symbol lookup error: 
/usr/local/lib/mythtv/plugins/libmythmusic.so: undefined symbol: 

When I run "nm /usr/local/lib/mythtv/plugins/libmythmusic.so -D -g", 
that symbol is there but undefined. What does it mean?

I am using Mandrake 10.1 with kernel 2.6.9 and GCC version 3.4.1. MythTV 
is compiled with DVB and ALSA, mythmusic is compiled with fftw and 
opengl support.


More information about the mythtv-dev mailing list