[mythtv] MythTV broken under Xinerama

Chris Tracy mythtv at adiemus.org
Mon Mar 8 14:24:03 EST 2004

	When running mythtv under xinerama, myth apps hang after the blue 
background is drawn, but before any buttons show up.  The problem only 
appears when mythtv runs on a server with xinerama enabled.  For instance, 
if I run the same binaries remotely to a non-xinerama server, they work 
fine.  If I run binaries from my working mythbox in the living room to the 
xinerama x-server on my primary workstation, it hangs at the blue 
background.  (NOTE: running a single head configuration with xinerama 
enabled does NOT expose this bug, unfortunately)

	Compiling with debug support, I get the following trace:

#0  0x0088dc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00c59aed in ___newselect_nocancel () from /lib/tls/libc.so.6
#2  0x0078dae2 in _XPollfdCacheDel () from /usr/X11R6/lib/libX11.so.6
#3  0x0078ea51 in _XRead () from /usr/X11R6/lib/libX11.so.6
#4  0x0078f5b3 in _XReply () from /usr/X11R6/lib/libX11.so.6
#5  0x007782f1 in XGetImage () from /usr/X11R6/lib/libX11.so.6
#6  0x021dc295 in QPixmap::convertToImage() const ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#7  0x00970be0 in ThemedMenuPrivate::paintButton(unsigned, QPainter*, bool, bool) (this=0x96c3568, button=0, p=0xbffaaa00, erased=true, drawinactive=true)
    at themedmenu.cpp:1672
#8  0x0096ff39 in ThemedMenuPrivate::drawInactiveButtons() (this=0x96c3568)
    at themedmenu.cpp:1509
#9  0x0096ed06 in ThemedMenuPrivate::parseMenu(QString const&, int, int) (
    this=0x96c3568, menuname=@0xbffaacd0, row=-1, col=-1)
    at themedmenu.cpp:1234
#10 0x0097448b in ThemedMenu::Init(char const*, char const*) (this=0x96c4568, 
    cdir=0x96c1e10 "/usr/local/share/mythtv/themes/blue", 
    menufile=0x80fe333 "mainmenu.xml") at themedmenu.cpp:2188
#11 0x00974245 in ThemedMenu (this=0x96c4568, 
    cdir=0x96c1e10 "/usr/local/share/mythtv/themes/blue", 
    menufile=0x80fe333 "mainmenu.xml", parent=0x96c5d50, 
    name=0x80fe32a "mainmenu") at themedmenu.cpp:2163
#12 0x08067dbd in RunMenu(QString) (themedir=
      {static null = {static null = <same as static member of an already 
seen type>, d = 0x9682828, static shared_null = 0x9682828}, d = 0x96d7df8, 
static shared_null = 0x9682828}) at main.cpp:510
#13 0x0806c4ab in main (argc=1, argv=0xbffab104) at main.cpp:957

	I'm running a Geforce FX 5200 on the primary head and a Geforce 2 
MX on the secondary head.  The behaviour is the same regardless of the 
driver used.  (I've tried 'nvidia', 'nv', and even 'vesa')

	Again, the EXACT same binaries run from the SAME server, work fine 

1) displayed on a remote, non-xinerama x server
2) displayed on the local server, in a single head configuration, with 
xinerama disabled
3) displayed on the local server, in a dual-head configuration, with 
xinerama disabled

	This doesn't seem to be the same problem described here:


	as keyboard input doesn't work.  (And making the mods suggested do 
not change myth's behaviour)

	Unfortunately, this is way beyond my coding skill to fix, but I 
thought the info would be useful, since I'm not the first person to have 
this problem:


	Let me know if any more info would be helpful.


More information about the mythtv-dev mailing list