[mythtv] Compile prob with debug setting

Ed Wildgoose lists at wildgooses.com
Wed Jul 21 14:31:50 EDT 2004

Hmm, so cvs from a few days back, and I change the settings.pro file to 
use debug and I then get this compile error:

g++ -Wl,-rpath,/usr/qt/3/lib -shared -Wl,-soname,libmythtv-0.15.so.0 -o 
libmythtv-0.15.so.0.15.0 cc.o vbi.o hamm.o lang.o commercial_skip.o 
frequencies.o guidegrid.o infodialog.o infostructs.o jitterometer.o 
minilzo.o NuppelVideoPlayer.o osd.o osdtypes.o programinfo.o 
recordingprofile.o remoteencoder.o remoteutil.o RingBuffer.o RTjpegN.o 
scheduledrecording.o ttfont.o tv_play.o videosource.o yuv2rgb.o 
progfind.o nuppeldecoder.o avformatdecoder.o recorderbase.o 
filtermanager.o vsync.o proglist.o videooutbase.o videoout_null.o xbox.o 
dbcheck.o profilegroup.o udpnotify.o channeleditor.o channelsettings.o 
osdsurface.o osdlistbtntype.o blend.o datadirect.o sr_dialog.o sr_root.o 
sr_items.o channel.o NuppelVideoRecorder.o tv_rec.o channelbase.o 
hdtvrecorder.o fifowriter.o videoout_xv.o mpegrecorder.o ivtvdecoder.o 
videoout_ivtv.o dvbrecorder.o dvbchannel.o dvbdiseqc.o dvbsections.o 
dvbcam.o dvbdev.o transform.o remux.o ringbuffy.o ctools.o dvbci.o 
moc_guidegrid.o moc_infodialog.o moc_osd.o moc_osdtypes.o 
moc_profilegroup.o moc_recordingprofile.o moc_scheduledrecording.o 
moc_tv_play.o moc_videosource.o moc_progfind.o moc_proglist.o moc_xbox.o 
moc_udpnotify.o moc_channeleditor.o moc_channelsettings.o 
moc_osdlistbtntype.o moc_sr_dialog.o moc_sr_items.o moc_sr_root.o 
moc_dvbrecorder.o moc_dvbchannel.o moc_dvbsections.o moc_dvbcam.o  
-L/usr/qt/3/lib -L/usr/X11R6/lib -L../libmyth -L../libavcodec 
-L../libavformat -lmyth-0.15 -lmythavcodec-0.15 -lmythavformat-0.15 
-lfreetype -lmp3lame -L/usr/X11R6/lib -lXinerama -lXv -lX11 -lXext 
-lXxf86vm -lqt-mt -lXext -lX11 -lm -lpthread
videoout_ivtv.o: file not recognized: File format not recognized
collect2: ld returned 1 exit status
distcc[19138] ERROR: compile on localhost failed
make[2]: *** [libmythtv-0.15.so.0.15.0] Error 1
make[2]: Leaving directory `/home/edward/mythtv/mythtv.test/libs/libmythtv'
make[1]: *** [sub-libmythtv] Error 2
make[1]: Leaving directory `/home/edward/mythtv/mythtv.test/libs'
make: *** [sub-libs] Error 2

If I change settings.pro to exclude the ivtv stuff then the error just 
appears somewhere else.  Any idea what the problem might be?

gcc 3.3.3 in use here, and on Gentoo.

Ed W

More information about the mythtv-dev mailing list