[mythtv] [PATCH] ViaSlice QMatrix

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Sun Jul 18 04:13:02 EDT 2004

mythtv-dev-bounces at mythtv.org <> wrote:
>> On my epia frontend computer I tried to change X resolution from
>> 800x600 to 720x576 since that matches more closely the tv resolution.
>> I have a widescreen tv as screen and I have setup the DisplaySize to
>> a 16:9 aspect ratio in x config file.
>> When I change x to use 720x576 the gui looks ok, but when I try to
>> playback a recording it looks as if parts of the rigth and botom
>> side is outside the screen. I have turned on the popup menu at exit
>> of a recording and it's only partialy visible. When I switch back to
>> 800x600 everything is fine again and playback is properly displayed. 
>> I adjusted the gui size in the setup menus so the frontend menus is
>> properly aligned with the tv screen, but I never checked the box
>> that said something about using the same for playback, so this
>> shoudn't be affecting playback. 
> That was what I was seeing. PLaying back a 720x576 recording
> in mplayer fixes the scaling.
> I think this is because X still uses 800x600 as virtual
> display for the
> TV playback. You can see what is happening in your xfree log.
> I'm using 1024x768 at the moment because the image seems sharper
> (doesn't realy make sense with 720x576 recordings, but it does)
> Steven

Good to know I'm not the onlyone seeing this.
Maybe it has something to do with 720x576 being a 5:4 ratio instead of 4:3,
maybe there is some asumtions that expects the resolution to have a 4:3

I just tried to switch to 720x576 and I think I found something.
If I play mpeg4 encoded recordings everything is fine, but if I play
something that was recorded from the dvb card, parts of the recording is
outside the tv screen.
So it seems like this is related to the mpeg2 acceleration.

I use mythtv 0.15.1 if that makes any difference.

More information about the mythtv-dev mailing list