[mythtv] MPEG2: Picture start, but no GOP

John Patrick Poet john at BlueSkyTours.com
Wed Jul 7 15:57:57 EDT 2004

Thanks for responding Daniel.

If I wanted to try and make it key off of I-Frames, what would it need to
look for?

I do not want to do anything which would break it for other streams.  Since
these channels are not HD, it is not that important to be able to decode
them, but it would be nice.  What is interesting, is that mplayer will play
the Transport Stream from these stations just fine, but Myth will not.

Transport Streams, Program Streams, MPEG2 are all still a bit of black magic
to me.  I guess I will have to settle down and learn this stuff.


On Wed, 7 Jul 2004, Daniel Thor Kristjansson wrote:

> MPEG2 doesn't require GOPs. Maybe if we just looked for the first
> I-Frame instead that would work. The lack of GOPs will break MPEG2
> editing too, so we might want to flag any streams without GOPs to
> be non-editable.
> -- Daniel
> On Wed, 7 Jul 2004, John Patrick Poet wrote:
> ]I am using an HD-2000 card to pull in HDTV material.  It works great
> ]with all of my digital over-the-air channels except for UPN and WB.
> ]Those two channels are owned by the same company here in Albuquerque.
> ]They do not broadcast in HD, but it is digital SD.
> ]
> ]In trying to diagnose the problem, it looks to me like there is NEVER a
> ]GOP start indicator.  It looks like it does occationally see a "Picture
> ]Start" indicator.  The notes at the top of hdtvrecorder.cpp indicate
> ]that Jason Hoos set it up such that a "Picture Start" indicator is "good
> ]enough", but it does not seem to work for my UPN/WB stations.
> ]
> ]Jason, if you are still on this list, can you give me some guidance on
> ]what to look for?
> ]
> ]Thanks,
> ]
> ]John
> ]
> ]_______________________________________________
> ]mythtv-dev mailing list
> ]mythtv-dev at mythtv.org
> ]http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
> ]

More information about the mythtv-dev mailing list