[mythtv] DirectFB + QTE

Derek Watson magic_cure at hotmail.com
Mon Jan 12 12:55:37 EST 2004

Thanks Wayne

The error isn't easily ignored since myth actually crashes at this point 
after displaying a green screen for about 2-3 seconds.

I get:

(*) DirectFB/Layer: Enabled 'FBDev Primary Layer'.
(!!!)  *** CAUTION [letting unprivileged IDirectFBDisplayLayer::GetSurface() 
call pass until cooperative level handling is finished] *** 
idirectfbdisplaylayer.c (147)
(*) DirectFB/Layer: Enabled 'NVidia Overlay'.
2004-01-12 17:44:52 Changing from None to WatchingLiveTV
(!) [ 1522:    0.000] --> Caught signal 11 (at (nil), invalid address) <--

I've just recompiled everything using the following settings:

./configure --with-gfxdrivers nvidia
make install

./configure -qt-gif -no-exceptions -disable-opengl -qt-imgfmt-png 
-qt-imgfmt-jpeg -qt-imgfmt-mng -thread -qt-sql-mysql -I/usr/include/mysql/

qmake mythtv.pro
make install

The myth UI works fine, it seems only to crash when it attempts to playback 
video on screen. This occurs in both the watch tv and watch recordings 

Any further ideas?


>From: "Wayne A. Hogue II" <mythtv at chiphead.net>
>Reply-To: Development of mythtv <mythtv-dev at mythtv.org>
>To: Development of mythtv <mythtv-dev at mythtv.org>
>Subject: Re: [mythtv] DirectFB + QTE
>Date: Mon, 12 Jan 2004 06:05:37 -0500
>Derek Watson wrote:
>>Hi folks
>>I'm having trouble getting myth working with DirectFB + QTE as per Wayne's 
>>instructions. Does anyone have any ideas what the error message below 
>>could mean? I'm using Gentoox and have tried using both the xboxfb and 
>>rivafb but neither seem to work.
>>I can manually set the overlay to triple buffer with "dfblayer -l 01 -b 
>>BACKVIDEO" without
>That's setting double not triple. The nvidia dfb driver used on the xbox 
>doesn't support triple. The errors can be ignored as they are only diags.
>mythtv-dev mailing list
>mythtv-dev at mythtv.org

Gaming galore at  http://xtramsn.co.nz/gaming !

More information about the mythtv-dev mailing list