[mythtv] Xbox build failure

Matt Ryan matt.ryan at xotech-llc.com
Mon Feb 9 18:08:03 EST 2004

I just upgraded to xebian 1.0 and set up 512mb of swap, it takes over 
300mb of ram to compile globalsettings.cpp

Now I just have to get xmame to work with mythgame with the xbox 
controller & xpad.o, never tried before


Spencer Jason E CONT DLVA wrote:
>>-----Original Message-----
>>From: Matt Ryan [mailto:matt.ryan at xotech-llc.com]
>>Sent: Friday, February 06, 2004 9:30 PM
>>To: mythtv-dev at mythtv.org
>>Subject: [mythtv] Xbox build failure
>>Started getting this build failure on both of my xbox's, it's
>>repeatable, every time I try to build the cvs I get the same error.
>>Debian, versions below..
>>Qmake version: 1.05a (Qt 3.1.2)
>>gcc -v
>>Reading specs from /usr/lib/gcc-lib/i386-linux/3.2.2/specs
>>Configured with: ../src/configure -v
>>--enable-languages=c,c++,java,f77,proto,pascal,objc,ada --prefix=/usr
>>--mandir=/usr/share/man --infodir=/usr/share/info
>>--with-gxx-include-dir=/usr/include/c++/3.2 --enable-shared
>>--with-system-zlib --enable-nls --without-included-gettext
>>--disable-__cxa_atexit --enable-java-gc=boehm 
>>--enable-objc-gc i386-linux
>>Thread model: posix
>>gcc version 3.2.2
>>Failure is..  (and no I didnt hit cntrl C)
>>g++ -c -pipe -Wall -W -O3 -march=pentiumpro -fomit-frame-pointer
>>-DQT_THREAD_SUPPORT -I/usr/share/qt3/mkspecs/default -I.
>>-I../../libs/libmythtv -I../../libs -I../../libs/libmyth
>>-I/usr/local/include -I/usr/share/qt3/include -o globalsettings.o
>>g++: Internal compiler error: program cc1plus got fatal signal 15
>>make[2]: *** [globalsettings.o] Error 1
>>make[2]: Leaving directory 
>>{standard input}: Assembler messages:
>>{standard input}:13226: Warning: end of file not at end of a line;
>>newline inserted
>>{standard input}:13472: Error: expecting operand after ','; 
>>got nothing
>>make[1]: *** [sub-mythfrontend] Error 2
>>make[1]: Leaving directory `/mythtv/mythtvtest/mythtv/programs'
>>make: *** [sub-programs] Error 2
> Sent a reply out earlier but never saw it hit the forums.  I am seeing the
> same
> error when compiling on the xbox.  Although I found a work around.  In
> short:
> cp your distro cd/iso to a new dir (hopefully on a faster machine)
> cp mythtv source to the new dir
> chroot the new dir
> source /etc/profile
> compile mythtv
> exit chroot
> cp/ftp binaries/libs to xbox
> This is so much better then compiling on the xbox.  I can't believe I didn't
> think
> of this earlier.  Hope this helps.
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list