[mythtv] mythvideo compile errors?

Mike Benoit ipso at snappymail.ca
Thu Aug 19 11:33:26 EDT 2004

On Thu, 2004-08-19 at 10:04 +0100, Colin Guthrie wrote:
> Mike Benoit wrote:
> > It seems your using GCC 3.3.2, whereas I'm using GCC 3.4.1. I wonder if
> > thats the difference? I don't see mathdef.h when I run:
> > 
> > g++ -M -D_REENTRANT -fPIC  -D_GNU_SOURCE -DPREFIX=\"%{_prefix}\"
> > -I/usr/lib/qt3/mkspecs/default -I. -I%{_prefix}/include
> > -I/usr/lib/qt3/include videogallery.cpp
> Hmmm, I guess there must be some sort of change in the internal makeup 
> of GCC 3.4.1 then. Perhaps things would work if you just add:
> #include <math.h>
> to videogallery.cpp. It shouldn't do any harm, although it may mess up 
> some floating point stuff (IIRC, some headers try to include some fp.h 
> file or something in preference to math.h, but I wont pretend to know 
> really!)

I updated to the latest CVS version, and tried your suggested
modification, but now I'm getting this error:

videobrowser.cpp: In member function `void VideoBrowser::updateInfo
videobrowser.cpp:378: error: 'class UIImageType' has no member named
make[1]: *** [videobrowser.o] Error 1
make[1]: Leaving directory `/root/tmp/mythvideo/mythvideo'
make: *** [sub-mythvideo] Error 2

It seems like someone is making some pretty major changes to mythvideo,
I think I'll just wait a while for things to settle down a bit for now.

Mike Benoit <ipso at snappymail.ca>

More information about the mythtv-dev mailing list