[mythtv] Recent scheduler.cpp changes introduced a bug.

Shawn Asmussen asmussen at cox.net
Tue Apr 20 18:00:14 EDT 2004

I ran into the scheduling problems discussed in this thread when I upgraded
to the current CVS a few days ago. I'm running FC1, and at the time I had
the stock mysql that ships with FC1 installed. When I came to the list and
found that the old version of mysql was the problem, I rooted around and
found this:


For anybody that's interested, the above page has very good instructions on
how to manually upgrade mysql on Fedora to 4.x, while still leaving things
configured the 'RedHat way'. I used those instructions to upgrade my mysql,
perl-DBD-mysql, qt-MySQL, and php-mysql, and after doing so, mythtv seems
pretty happy, and all of my vanished scheduled recordings have returned.
Including compile time for all of the above packages, the whole thing only
took a couple of hours. 

The only changes I made to the instructions, were that they were written for
4.0.17, and 4.0.18 is available now, so I downloaded that src.rpm, and
edited the spec file provided on the website to reference .18 instead of
.17. Also, I had to use --nodeps when uninstalling the old perl-DBD-MySQL.
Other than that, there weren't even any bumps. It was a lot less hassle than
I expected it to be. I backed the mythconverg database, and was half
expecting to end up fighting to restore the data after I was done, but once
I had everything built, and upgraded using rpm, everything just worked.
First time for everything I guess...

If anybody wants the 4.0.18 rpms I built for FC1, I put them up here:


If you go there, ignore the certificate warning. It's just because I'm using
a self signed certificate for SSL, plus it expired and I haven't bothered
renewing it, since I just use it for personal use... It's just a cable modem
connection, so be patient, and the only rpms you probably actually need are:


I put up all of the rpms that I built, although for qt, and php, as far as I
know you only actually need the -mysql package, but for php and qt, there
are many rpms that come from the same source rpm, and when you do an rpm
--rebuild on the source rpm, you end up with new rpms for everything.

Of course, if anybody does decide to use those rpms instead of building
their own, they are provided completely as is with no guarantees whatsoever.
I've been using them for less than a day myself, so although everything
looks good, I can't guarantee that nothing will go wrong.

If the new mythtv code is going to require mysql 4.x, then I would imagine
that one way or another most of the Fedora users out there are going to want
to make the upgrade at some point, although it will make keeping your FC1
system up to date a little harder, since if RedHat releases updates to qt,
or php, or perl-DBD, then you have to grab the source rpm and rebuild it
yourself again. Maybe one of the rpm repositories like ATrpms will start
carrying the needed packages...

Shawn Asmussen

-----Original Message-----
From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Anduin Withers
Sent: Monday, April 19, 2004 12:52 PM
To: 'Development of mythtv'
Subject: RE: [mythtv] Recent scheduler.cpp changes introduced a bug.

> you shouldn't see any
> record table entries with a missing station, and if you do, restarting
> the master backend should fix it.

You are only partially correct.

There have been a lot of mysql >= 4.x things going in recently, this
"auto-fix on start" thing is one of them (as well as the stuff in

This is bad news for Fedora users, who won't be seeing a newer mysql anytime

More information about the mythtv-dev mailing list