[mythtv] Separating CAPTUR and Capture in OSS

Michael Kedl kedlm at knology.net
Thu Mar 6 11:26:26 EST 2003

I am currently using RedHat 8.0 and have rebuilt the alsa stuff probably
about a dozen times on 7 or so different machines of which 4 are running
mythtv (some frontend, some backend, some both).  Everything seems to
work fine.  I suggest you try building it, I have had no problems.  just
make a nice list of stuff in /etc/rc.local to start by hand if you want
(I prefer this instead of futzing with the autoloader stuff)

I am using 0.9.0rc5.

Good Luck,

On Wed, 2003-03-05 at 17:41, Robert Middleswarth wrote:
> I think that freshrpm.net does a pretty good job of keeping up with its 
> RPM from what I can tell but I wish Redhat would make native ALSA driver 
> avaible.
> Robert Cantu wrote:
> >I know that most of you are running Debian or SuSE, but RedHat does not come
> >with alsa so you have to either 1) build from source or 2) get
> >kernel-version locked prebuilt packages (these usually don't cover modules
> >built against the newest RedHat up2date kernels). Please no flames about RH.
> >
> >Robert Cantu, RHCE
> >
> >-----Original Message-----
> >From: mythtv-dev-bounces at snowman.net
> >[mailto:mythtv-dev-bounces at snowman.net]On Behalf Of Matt Zimmerman
> >Sent: Tuesday, March 04, 2003 8:37 PM
> >To: Development of mythtv
> >Subject: Re: [mythtv] Separating CAPTUR and Capture in OSS
> >
> >
> >On Tue, Mar 04, 2003 at 07:46:04PM -0600, Robert Cantu wrote:
> >
> >  
> >
> >>I run mythtv with the stock emu10k1 on RedHat 8.0 with my SB Live! PCI
> >>card.  I've also tried it with Alsa from source. I can honestly say that
> >>the OSS driver is much better. With alsa, I get horrible audio performance
> >>when I fast forward or rewind recorded or live TV. That and it's just
> >>cleaner not to have 10+ modules that you have to hand load in most cases
> >>(modprobe snd-emu10k1 doesn't load the oss-pcm or oss-mixer modules), not
> >>to mention that you have to handle the case of automatically muted Master
> >>and PCM channels in the mixer everytime you load the drivers. For RedHat,
> >>I find that alsa just gets in the way (it handles the OSS mixer load/save
> >>already after an install) for performance that is either negligible or
> >>non-existent for 98% of cases needed. I'm not saying it's not a good
> >>project, I'm just saying that MythTv (and it's developers) shouldn't force
> >>alsa on the user if the oss driver performs the same or better (as it does
> >>in the case of emu10k1).
> >>    
> >>
> >
> >If you would use your vendor's ALSA packages, the administration problems
> >that you have would go away.  They take care of loading the modules
> >properly, saving and restoring mixer settings, etc.  Thee are not inherent
> >problems with ALSA.
> >
> >--
> > - mdz
> >  
> >
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-dev
Michael Kedl <kedlm at knology.net>

More information about the mythtv-dev mailing list