[mythtv] LIRC irexec not working for me

David Won phlegm at rogers.com
Fri Jun 20 16:25:36 EDT 2003

Hey all I just got a new HetEye serial ir receiver and have 
been trying to get it to work in myth. 
I got the kernel compiled correctlyand the correct lirc modules loaded. 
I copied the /etc/lircd.conf file for my remote. 
I edited the .lircrc file but can't get it to do anything with myth.
I have tried running irexec as root and my myth user.
It does work with echoing a command to a term window as in the lirc 
example on their web page.
I tried replacing  config = Key Down CurrentWindow
with  config = Key Down mythfrontend but it made no difference.
It seems to be a focus problem maybe but changing the focus made no difference.
I'm running the latest CVS and running Redhat 9 using KDE.
Any ideas on what I can try next?

btw: The jitter reduction works much better in the CVS. It was broken for me in 9.0

Thanks for any help.

Here is a snippet from my .lircrc file.
    prog = irxevent
    button = chanup
    config = Key Up CurrentWindow

    prog = irxevent
    button = chandown
    config = Key Down CurrentWindow

    prog = irxevent
    button = exit
    config = Key Escape CurrentWindow

    prog = irxevent
    button = guide
    config = Key M CurrentWindow

More information about the mythtv-dev mailing list