[mythtv] mythmusic segfault

Mark Jacob mjacob1 at san.rr.com
Thu Jun 5 22:53:58 EDT 2003

I noticed that there was another commit to mythmusic a little while ago. 
I am in the middle of recompiling... hopefully it will fix my issues.

On a side note I tried running mythmusic in gdb. I had to handle SIGPIPE 
and SIG32, and while i didn't see any SIGPIPEs I did see a few SIG32 
events fire. I setup a playlist, press play, and eventually execution 
stops with a SIGSEGV. I then typed thread apply all bt full at the gdb 
prompt and got absolutely nothing. Do I need a newer version of gdb?


Isaac Richards wrote:
> On Thursday 05 June 2003 11:26 pm, Mark Jacob wrote:
>>Sorry about the bad gdb output Issac. :( I just repro'ed the segfault
>>again and here's the gdb output according to the howto. To answer the
>>questions below, there aren't any console messages printing out... just
>>the segfault. I have 120GB of mp3's, and I select a single album to play
>>(doesn't matter which album) and hit play before it crashes.
> Sorry, I wasn't clear enough -- you need to have crashed it while it was 
> running in gdb and get the backtrace that way, and not generated the 
> backtrace from a core file like you are.  Multithreaded core dumps on linux 
> don't work all that well.
> Isaac
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at snowman.net
> http://lists.snowman.net/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list