[mythtv] Please help me provide a backtrace

Dave Caplinger dent at cox.net
Sat Feb 15 15:29:08 EST 2003

I'm apparently one of many people that can no longer get CVS to run with
LiveTV.  I've recompiled with debugging turned on (complete rebuild
including make distclean, rm /usr/local/lib/libmyth*, etc.  Yes, I ran
'setup', and mythfilldatabase runs fine.) and tried to get my frontend
machine (cyan) to display LiveTV from my backend machine (scribe).  The
problem is that I reproduce the crash, but gdb says there is no stack. 
If anyone has any hints on where to go next, I would certainly
appreciate them!

Here's gdb's output:

(gdb) run
Starting program: /usr/local/bin/mythbackend
[New Thread 16384 (LWP 26285)]
Probed: /dev/video - Television
Probed: /dev/video - Composite1
Probed: /dev/video - S-Video
Probed: /dev/video - Composite3
[New Thread 32769 (LWP 26290)]
[New Thread 16386 (LWP 26291)]
[New Thread 32771 (LWP 26292)]
Pruning duplicate program (already recorded):
The Simpsons
Special Edna
Bart nominates Mrs. Krabappel for Teacher of the Year.
Sun Feb 23 18:00:00 2003
adding: cyan as a player 1
adding: cyan as a player 0
[New Thread 49156 (LWP 26345)]
adding: cyan as a player 0
adding: cyan as a remote ringbuffer
[New Thread 65541 (LWP 26346)]
Changing from None to WatchingLiveTV
[New Thread 81926 (LWP 26347)]
[New Thread 98311 (LWP 26348)]
[New Thread 114696 (LWP 26349)]
[New Thread 131081 (LWP 26350)]
/usr/local/bin/mythbackend: ¤úŸ¾Cå     C+

Program exited with code 0315.
(gdb) bt
No stack.
(gdb) info threads
No stack.

Dave Caplinger <dent at cox.net>

More information about the mythtv-dev mailing list