[mythtv] Illegal instruction when I run mythtv

Brent Borghese brent at bborghese.com
Sat Feb 15 04:25:11 EST 2003

I tried that.  It does not work!

If I change the settings.pro file to -march=k6-2 every thing that gets 
compiled with g++ looks like it works:

g++ -c -pipe -Wall -W -O6 -march=k6-2 -fomit-frame-pointer -funroll-loops 
-fexpensive-optimizations -finline-functions -D_REENTRANT  -D_GNU_SOURCE 
-DQT_THREAD_SUPPORT -I/usr/local/include -I../libs 
-I/usr/lib/qt3-gcc3.2/include -I/usr/lib/qt3-gcc3.2/mkspecs/default -o 
main.o main.cpp

But, any thing compiled with gcc does not get the setting:

gcc -c -pipe -Wall -W -I/usr/include/fontconfig -I/usr/include/Xft2 -O2 
-march=i386 -mcpu=i686 -fno-use-cxa-atexit -fno-exceptions  -D_GNU_SOURCE 
-DPREFIX=\"/usr/local\" -DEXTRA_LOCKING -DMMX -I/usr/local/include 
-I/usr/lib/qt3-gcc3.2/mkspecs/default -o dummy.o dummy.c

It has a setting of -mcpu=i686 that is causing the problem.

What do I need to do to get qmake to make Makefile's with the right 
-march setting?



>>>>>>>>>>>>>>>>>> Original Message <<<<<<<<<<<<<<<<<<

On 2/13/03, 11:06:32 PM, Bruce Markey <bjm at lvcm.com> wrote regarding Re: 
[mythtv] Illegal instruction when I run mythtv:

> Brent Borghese wrote:
> ...
> > I then build a second computer to be my front end.   It is a K6-2 500Mhz,
> > running RH 8 and the same CVS version of myth.
> ...
> > If I run setup or mythfrontend, I get a "Illegal instruction".

> http://www.mythtv.org/docs/mythtv-HOWTO-17.html#ss17.1

> --  bjm

> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list