[mythtv] WinTV PVR-250 Install/Config

Ron Kellam ron at haliplex.com.au
Tue Aug 19 10:25:32 EDT 2003


I had this sort of problem a few weeks back.

First, check /proc/interrupts - look at the interrupt count for the ivtv related interrupt - from the sort of errors you're reporting (the "EOS interrupt not received" message), it's probably 0.  If so, it indicates the ivtv card is not operating correctly - probably a card initialisation problem...

In my case, the problem was that the various ivtv related header files that define the ioctl constants were out of sync.

I think the ivtv driver uses /usr/src/linux/.../video/videodev2.h (or something like that).
The test_ioctl program may use the local videodev2.h in the ivtv/utils directory.
MythTv uses its own version of this file (can't quite remember which file).

If the ioctl definitions don't all agree, then you'll have problems, as the card probably won't be getting initialised properly.

Cheers,

Ron

-----Original Message-----
From: Adam Leach [mailto:mythtv-dev at ask-adders.co.uk]
Sent: Tuesday, 19 August 2003 7:41 AM
To: mythtv-dev at mythtv.org
Subject: [mythtv] WinTV PVR-250 Install/Config


Hi All,

I'm new to MythTV and in the process of trying to get MythTV working,
but have encountered the following problem.

I get the following when trying to get the card working.  Machine is an
Athlon running SuSE 8.2.

Aug 18 21:57:00 dev2 kernel: ivtv: Found an iTVC15 based chip
Aug 18 21:57:00 dev2 kernel: tuner: probing ivtv i2c driver #0 i2c
adapter [id=0x10005]
Aug 18 21:57:00 dev2 kernel: tuner: chip found @ 0xc2
Aug 18 21:57:00 dev2 kernel: tuner(bttv): type forced to 5 (Philips
PAL_BG (FI1216 and compatibles)) [insmod]
Aug 18 21:57:00 dev2 kernel: msp3410: daemon started
Aug 18 21:57:02 dev2 kernel: status: (1E) 0x50, (1F) 0xc0
Aug 18 21:57:05 dev2 kernel: ivtv: Encoder revision: 0x02030207
Aug 18 21:57:05 dev2 kernel: ivtv: Decoder revision: 0x02020001
Aug 18 21:57:05 dev2 kernel: ivtv: Registered v4l2 device, minor 0
Aug 18 21:57:05 dev2 kernel: ivtv: Registered v4l2 device, minor 32
Aug 18 21:57:05 dev2 kernel: ivtv: Registered v4l2 device, minor 224
Aug 18 21:57:24 dev2 kernel: ivtv: ivtv-api.c: unknown ioctl 0x80585600
Aug 18 21:57:24 dev2 kernel: ivtv: ivtv-api.c: unknown ioctl 0xc0405602
Aug 18 21:57:24 dev2 kernel: ivtv: ivtv-api.c: unknown ioctl 0xc0cc5615
Aug 18 21:57:24 dev2 kernel: ivtv: qctrl: invalid control
Aug 18 21:57:24 dev2 last message repeated 22 times

Aug 18 21:57:44 dev2 kernel: Hpsc: 0x00001, Hfsc: 0x00780
Aug 18 21:57:44 dev2 kernel: Vsrc: 576, Vscy: 0x00800
Aug 18 21:57:47 dev2 kernel: ivtv: Timeout waiting for data!
Aug 18 21:57:52 dev2 kernel: Hpsc: 0x00001, Hfsc: 0x00780
Aug 18 21:57:52 dev2 kernel: Vsrc: 576, Vscy: 0x00800
Aug 18 21:57:55 dev2 kernel: ivtv: Timeout waiting for data!
.............
Aug 18 21:58:52 dev2 kernel: ivtv: Timeout waiting for data!
Aug 18 21:58:53 dev2 kernel: ivtv: EOS interrupt not received! stopping
anyway.

xawtv loads, however doesn't return any picture.  kwintv fails.  I'm
based in UK so trying to get the PAL decoder working.

I would be extremely grateful for any help.

Regards

Adam





More information about the mythtv-dev mailing list