[mythtv] Fw: [mythtv-users] Myth is locking soundcard andpreventing fullduplex operation

Edward Wildgoose edward.wildgoose at frmhedge.com
Wed Apr 16 16:29:19 EDT 2003

> On Tuesday, April 15, 2003, at 05:43  PM, Edward Wildgoose wrote:
> > Nope, killed all that junk to be sure.  Literally when mythbackend is
> > running, but not recording, then I can use arecord and aplay
> > simultaneously
> > (gives a kind of delayed tv sound when xawtv is running).
> >
> > However, while arecord is running, trying to fire up xmms gives error
> > messages about the device being locked.  A similar but slightly
> > different
> > message appears if I try and run up xmms while mythtv is recording.
> >
> > I *can* then play back the recorded tv show with sound once myth has
> > finished recording, but there is no sound if I try and play while myth
> > is
> > still recording, so something is definitely happening during record
> > which is
> > locking the sound device.
> I believe myth uses OSS to record/playback, so it would be going
> through the ALSA OSS emulation layer. aplay and arecord do *not* use
> the OSS emulation layer of ALSA, they use the ALSA interface directly.
> What it sounds like you're seeing is that the ALSA OSS emulation layer
> thinks your sound card is not capable of full-duplex for some reason,
> but the direct ALSA interfaces think it is. I would try this to test my
> theory:
> cat /dev/dsp > /dev/dsp

Hmm, this was an excellent suggestion.  Just tried it and it works fine -
with xawtv I basically get live sound if I run this command

I had a browse through the libmythtv code and it appears to only open
read-only and write-only for record and play so there are no obvious issues.
There is some changing of modes though (frequency, etc) which could be an
issue?  The default record frequency from /dev/dsp appears to be 8khz.

Any ideas on where to look next please?

> Also out of interest what does ls /dev/sound have in it?


More information about the mythtv-dev mailing list