[mythtv] 3 problems: sound, switch to tv, failure to quit

Cedar McKay mythtv-dev@snowman.net
Mon, 28 Oct 2002 21:50:41 -0800

Hi, I'm using an oct 26 snapshot of the cvs, RH8. I finally got 
everything compiled, installed, and now I have a couple of issues to 
work out. I'm getting pretty excited, everything looks really slick, 
polished and I think the gui is going to be great.

1) sound issues:  I'm having some sound sync issues, the sound far 
ahead of video problem mentioned in the faq.  The faq instructs me to 
mute the line in etc etc. Now I have no sound. It occurs to me that in 
the myth command line setup routine, the default video device was 
called /dev/video, where mine was really /dev/video0 which I discovered 
via xawtv. Is it possible that the default sound device is also not 
appropriate for me? Would the setup program complain if I had the wrong 
sound device chosen? How do I figure out what my device name my sound 
card is actually using? ps, the sound card is working for other apps.

2)if I run the command line app mythtv I successfully can watch tv, 
pause, ff, rewind etc, all perfectly except for the sound issue 
mentioned above. Similarly mythfrontend seems to be working ok too. I 
can schedule shows, resolve conflicts etc, but I can't switch to 
watching live tv. I've tried it a few times and it either just pretends 
that I haven't pushed the live tv button, or once, switched to a 
picture of the blue background. No tv in site though. As a side note, I 
assume the "setup" button doesn't do anything yet? Not on mine anyway.

3)finally, mythtv and mythfrontend seem to have a bit of a life of 
their own. Mythtv takes over the screen, obscuring other apps, and if I 
try to select other running apps via the control strip at the bottom, 
or perhaps switch to a different virtual desktop, mythtv refuses to 
give up. The only way I can quit it is to use a contextual menu on the 
mythtv icon in my control strip, the blindly grope (or use a key combo) 
for the "close" option, because mythtv obscures any menus I manage to 
open. mythfrontend is even worse. It completely hides my desktop (which 
is good until I want to quit), doesn't let me select another app, hides 
the control strip, and does not respond to the esc key, control-c or 
anything else I can think of. I end op having to kill x11 in order to 
quit the darn thing.

oh, is there a comprehensive list of key strokes and commands that the 
mythapps use  that I've missed somewhere?

Great job Isaac! You have a tivo killer on your hands with just a 
little more work!