[mythtv] problems with installing xmltv

Harondel J. Sibble mythtv-dev@snowman.net
Fri, 25 Oct 2002 23:38:34 -0700

Howdy folks, having a bit of troubles compiling xmltv so that I can get 
mythtv up and running.

Following is email I sent to the xmltv developer and one other list.  Hope 
someone can shed some light on how to solve the problem.....



Howdy folks, I am trying to compile xmltv 0.52 (on MDK 8.2) which is a 
prerequiste to run MythTV, a linux PVR package.  Now, one of the required 
perl modules is Tk:TableMatrix. Whether I go the cpan route or try to compile 
it myself I get the same results:

Using -L/usr/X11R6/lib to find /usr/X11R6/lib/libX11.so.6.2
Using -I/usr/X11R6/include to find /usr/X11R6/include/X11/Xlib.h
Cannot find Tk/pTk/Lang.h in @INC
Running make test
  Make had some problems, maybe interrupted? Won't test
Running make install
  Make had some problems, maybe interrupted? Won't install

The 3rd line down seems to be the critical error.  I did a google search on 
the Lang.h file, but haven't seen anything that appears relevant. 

The offending line in the Makefile.PL appears to be 

# Find path to existing pTk include files
my $ptkPath = Tk::MMutil::findINC('Tk/pTk/Lang.h');
$ptkPath =~ s/\/Lang.h$//g;

Since Tk:MMutil is mentioned, I installed that and and now the 
Tk::TableMatrix module gets futher in compiling.

Odd that the docs wouldn't mention needing that module since the Tk::MMutil 
took about 10-15 minutes to compile as opposed to under a minute for the 

Okay, I try to install Tk::TableMatrix and now get this:

LD_RUN_PATH="" cc  -shared -L/usr/local/lib TableMatrix.o  -o 
blib/arch/auto/Tk/TableMatrix/TableMatrix.so pTk/libpTk.a  -L/usr/X11R6/lib 
-lX11 -lpt -lnsl -lm
/usr/bin/ld: cannot find -lpt
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/Tk/TableMatrix/TableMatrix.so] Error 1
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Is -lpt a missing function of ld?

I am currently downloading some updates for 8.2 that I must have missed, one 
of which is slighty newer version of glibc. Just tried again with the newer 
version of glibc and still get the same error.

Any ideas?