[mythtv] RE: problem watching recording in progress and recording new programs

Carlos Talbot mythtv-dev@snowman.net
22 Nov 2002 17:39:39 -0600


Mark,

I had a similar problem with an external script to control my digital
cable box. The solution was to change the bourne shell script which
calls the perl script into csh.

See here:
http://www.snowman.net/pipermail/mythtv-dev/2002-November/001569.html



On Fri, 2002-11-22 at 17:14, Mark Naudain wrote:
> Matt,
> fuser didn't provide any causes, but my troubleshooting finally
> provided and anwer. Thanks for the help, anyway.
> 
> I finally figured out my problem with recording.
> I am using a perl script to control my satellite box via serial port.
> Using this program to switch channels seemed to cause a few glitches in
> the sound/video when switching channels viewing "live" tv, so I made
> the program run detached with "&" from the script I was calling.
> I took out the & from the script and all is well again.
> 
> Thanks,
> Mark
> 
> > I have more information regarding the problem I am having watching a
> > recording (watching live tv is no problem for me)
> > I didn't have this problem until a few days ago and am a little
> > stumped. Any help would be appreciated.
> > 
> > Thanks,
> > Mark
> > 
> > Here is the output:
> > 
> > Changing from None to RecordingOnly
> > Can't open video device: /dev/video0
> > open video:: Device or resource busy
> > VIDIOCSAUDIO: Bad file descriptor
> 
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus  Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev@snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-dev