[mythtv] no video with mythtv

Emil Friis mythtv-dev@snowman.net
Mon, 18 Nov 2002 06:10:46 -0800 (PST)

As you might have seen from the thread this weekend I just
got a second card and got it working with some help from
Isaac. Thanks for the help Isaac - I'm planning to write a
little doc on it that can be included in the existing

My biggest problem was that I did not have audio set up
correctly. As it turned out it seems none of my cards
support btaudio - the module will load no problems but I
don't get any sound. To get around that I had to enable the
onboard audio which wasn't that easy - I ended up having to
patch the kernel because of some issues with devfs and the
way some of the sound components were loaded. Anyway - my
point is that if audio doesn't work correctly Myth might
very well die/hang, so make sure you can get the audio to
work with Xawtv or something like it.

After spending half the weekend on it i got PiP to work but
I did come across a couple of issues:

- When I toggle controls to the PiP I can only enter 1 digit
- meaning I have to scroll one channel at a time to get
anywhere above 9.
- This is made even more difficult by the fact that there is
no OSD to show what channel you are on except if you press
i. I would suggest adding an OSD that shows the channel no.
of the PiP as you are changing - maybe somewhere else than
the main window channel no. and another color.
- Which leads to another issue - it is very difficult to
figure out which window has the controls. How about adding a
frame around the PiP that is black when the main window has
controls and white when the PiP is active. That way you
could use the channel no. OSD from the main window when
changing channels and it would still be obvious which window
the number belongs to.
- I had somewhat the same problem as Harondel when it comes
to recording a show and trying to watch another channel.
When recording a show I tried to watch tv and it came up
with the usual "Watch show being recorded..." etc. How do I
watch live on one card and record on the other?
- I did manage to record two shows at the same time and one
turned out ok while the other seemed to suffer from the same
IO-bound issues (slowing down of both audio and video)I saw
before getting my new drive. maybe I should put both
ringbuffers on my main drive and just use the other for

Anyways... Since I don't really know how to program i can
only contribute by documenting my problems + solutions.

And again - thanks for the help Isaac - as usual it wasn't a
Myth problem but a user/environment problem...


On Mon, 18 Nov 2002 05:47:23 -0800 (PST), "Harondel J.
Sibble" wrote:

> Well after a weekend getting dual tv cards working, I am
> back to my original 
> setup... sort of and no video from mythtv.
> Basically the steps I took as I remember it are:
> 1) recompiled the kernel to resolve some issues I was
> with he ide 
> driver from my last compilation hanging on bootup.  Added
> the btaudio driver 
> as a module etc.
> 2) added the 2nd tv card, the original was an ATI TV
> while the 
> secondary card was an Aims Labs Video Highway Extreme,
> much mucking 
> about with modules etc, I got both cards working with
>  For those who 
> want to try this, here is the relevant section of my
> /etc/modules.conf
> alias char-major-81 bttv
> options bttv card=63,14 bttv_verbose=2 tuner=2,2 pll=1,1
> post-install bttv modprobe -k tuner
> post-install bttv modprobe -k btaudio
> post-remove bttv modprobe -r tuner
> post-remove bttv modprobe -r btaudio
> The last 4 lines are probably not necessary, but ymmv.
> 3) I installed the commercial OSS drivers and then
> uninstalled them as I 
> couldn't control the volume wrt mythtv or xawtv from
> Anyhow, after I got this up and running, I tried running
> mythtv and all I got 
> was the usual info in the term window, I could hear the
> audio in the 
> background, but, not video window. Same result if I went
> through 
> mythfrontend.  Oddly enough before I had got both cards
> running I had set a 
> recording to record a show.  I had everything running
> the same time as 
> the show would have been recorded. When I started up myth
> from either the 
> frontend or mythtv, it would say that myth was already
> recording the show and 
> would I like to watch recording in progress, I select yes
> and it comes up, 
> but it's quite jerky.  Hitting V to switch to the other
> tuner fails. 
> Basically then I have to escape to get out of myth.  I hit
> esc to get back to 
> the frontend, then have to go to the terminal window and
> ctrl-c to kill 
> the frontend, as it just sits there with the logo in the
> background but no 
> buttons.
> One the recording time period was up, if I started up myth,
> I'd get sound but 
> no picture.
> Since then I've removed the second card and rerun the
> ./configure, make, make 
> install steps, copied back my settings.txt that I'd
> previously backed up and 
> all I get is sound but no video.
> Any suggestions on what I should be looking it?
> Oh just remembered one other item but I suspect it's may
> be related. 
> Since I recompiled the kernel, I had to reinstall the
> binary drivers.
> Other than that, I can't think of any thing else.
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev@snowman.net
> <a